Bug 618868 - Flash/NSPluginWrapper doesn't seem to work (hangs, and then nspluginwrapper dies), x86_64
Flash/NSPluginWrapper doesn't seem to work (hangs, and then nspluginwrapper d...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 18:09 EDT by James Antill
Modified: 2010-07-30 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 12:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2010-07-27 18:09:38 EDT
Description of problem:
 I've just changed desktops and I can't seem to run flash against anything, on x86_64. Running firefox from the cmd line gives:


Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:1858):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** ERROR: NPP_Write() wait for reply: Message timeout
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:2239):invoke_NPP_DestroyStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:1927):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:1977):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))

...flash _seems_ to die when it gets to displaying pretty much anything (in that on some sites it will do a large download, and then it'll die).

Version-Release number of selected component (if applicable):

% yum lsi firefox xulrunner nspluginwrapper
[...]
firefox.x86_64                          3.6.7-1.fc13                    @updates
nspluginwrapper.i686                    1.3.0-14.fc14                   @rawhide
nspluginwrapper.x86_64                  1.3.0-14.fc14                   @rawhide
xulrunner.x86_64                        1.9.2.7-2.fc13                  @updates

...also from the Fedora docs:

% yum lsi flash-plugin nspluginwrapper alsa-plugins-pulseaudio libcurl
[...]
alsa-plugins-pulseaudio.i686   1.0.22-1.fc13      @fedora                       
alsa-plugins-pulseaudio.x86_64 1.0.22-1.fc13      @anaconda-InstallationRepo-201005130101.x86_64
flash-plugin.i386              10.1.53.64-release @adobe-linux-i386             
libcurl.i686                   7.20.1-3.fc13      @updates                      
libcurl.x86_64                 7.20.1-3.fc13      @updates                      
nspluginwrapper.i686           1.3.0-14.fc14      @rawhide                      
nspluginwrapper.x86_64         1.3.0-14.fc14      @rawhide        


How reproducible:
Always
Comment 1 James Antill 2010-07-27 18:10:59 EDT
Forgot to mention, I was getting (again, no input, just start and hang/die):

*** NSPlugin Viewer  *** WARNING: unhandled variable 18 (<unknown variable>) in
NPN_GetValue()

...but then I got the nspluginwrapper from rawhide, due to BUG 607884 ... but while that fixed the message, it still doesn't work.
Comment 2 Kieran Clancy 2010-07-28 01:48:26 EDT
I am seeing this as well.
Comment 3 James Antill 2010-07-30 12:54:22 EDT
No idea how or why, but I brought up "the lama song" in flash, as I figured it was a really simple/old flash thing to test ... and that worked. After that point everything worked as well as it always did.

Don't ask me how or why :).

Note You need to log in before you can comment on or make changes to this bug.