Bug 618905 - ipeth should not be devtype WWAN
Summary: ipeth should not be devtype WWAN
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-28 02:43 UTC by Jason Montleon
Modified: 2011-03-17 06:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 06:01:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Montleon 2010-07-28 02:43:05 UTC
Description of problem:
With kernerl 2.6.34 the ipheth driver is available. This allows an iphone to show up as a wwan0 interface when plugged in via USB and all that's necessary to start tethering is run dhclient wwan0. NetworkManager does not see or want to manage the interface though.

Version-Release number of selected component (if applicable):
kernel-2.6.34.1-29.fc13.x86_64
NetworkManager-0.8.1-1.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-2.6.34.1-29.fc13.x86_64
2. Plug iphone in with USB cable
  
Actual results:
Works if you run dhclient, but not via NetworkManager

Expected results:
Should be able to manage interface in NetworkManager

Additional info:
Bus 002 Device 007: ID 05ac:1292 Apple, Inc. iPhone 3G

wwan0     Link encap:Ethernet  HWaddr 00:21:E9:7B:68:51  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Comment 1 Jason Montleon 2010-07-28 03:58:15 UTC
Possibly related to https://bugzilla.redhat.com/show_bug.cgi?id=585214 ?

I downgraded to a prior version than what's listed there and it more or less works (doesn't seem to stop the tethering on the phone when you disconnect)

Comment 2 Dan Williams 2010-08-17 16:52:56 UTC
So ipeth only needs the pairing to happen once per connection and that normally happens with udev.  I don't think ipeth should really be setting devtype WWAN, since that's usually reserved for devices like Option and Ericsson 3G modems that require a ton of AT command setup on a TTY before their ethernet devices work.

So in short, I don't believe ipeth should be setting devtype WWAN at all.

Comment 3 Jason Montleon 2010-08-17 17:35:48 UTC
I believe originally it was not a wwan device, but changed based on comments: http://lkml.org/lkml/2010/4/7/380 and http://lkml.org/lkml/2010/4/7/380

Comment 4 Chuck Ebbert 2010-08-19 01:45:48 UTC
(In reply to comment #2)
> So ipeth only needs the pairing to happen once per connection and that normally
> happens with udev.  I don't think ipeth should really be setting devtype WWAN,
> since that's usually reserved for devices like Option and Ericsson 3G modems
> that require a ton of AT command setup on a TTY before their ethernet devices
> work.
> 
> So in short, I don't believe ipeth should be setting devtype WWAN at all.

This needs to be taken upstream and reported to the netdev list. I'm not qualified to argue for a change like that.

Comment 5 Jason Montleon 2011-03-16 03:44:02 UTC
ipheth creates an eth interface in F15 now


Note You need to log in before you can comment on or make changes to this bug.