Bug 618914 - Windows 2008 (32bit) virtio block/nic BSOD while booting
Windows 2008 (32bit) virtio block/nic BSOD while booting
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 23:43 EDT by Cao, Chen
Modified: 2010-07-29 03:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 03:48:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Windows2008 virtio BSOD while booting (18.37 KB, image/png)
2010-07-27 23:49 EDT, Cao, Chen
no flags Details

  None (edit)
Description Cao, Chen 2010-07-27 23:43:45 EDT
Description of problem:

BSOD info:
---
DRIVER_IRQL_NOT_LESS_OR_EQUAL
...
*** viostor.sys - Address 8c540cc5 base at ...


Version-Release number of selected component (if applicable):
1.1.8-0


How reproducible:
10%


Steps to Reproduce:
1. command:
qemu-kvm -name 'vm1' -monitor unix:'/tmp/monitor-humanmonitor1-20100726-102637-6qrG',server,nowait -drive file='/tests/kvm/isos/windows/winutils.iso',if=none,id=drive-ide0-0-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -serial unix:'/tmp/serial-20100726-102637-6qrG',server,nowait -drive file='/tests/kvm/images/win2008-32-virtio.qcow2',if=none,id=drive-virtio-disk1,media=disk,cache=none,boot=on,format=qcow2 -device virtio-blk-pci,drive=drive-virtio-disk1,id=virtio-disk1 -net nic,vlan=0,netdev=idAZP1MB,model=virtio,macaddr='02:03:CA:FB:bb:bd' -netdev tap,id=idAZP1MB,ifname='virtio_0_8000',script='/tests/kvm/scripts/qemu-ifup-switch',downscript='no',vhost=on -m 4096 -smp 2 -vnc :0 -spice port=8000,disable-ticketing -rtc base=localtime,clock=host -M rhel6.0.0 -usbdevice tablet -cpu qemu64,+sse2 -no-kvm-pit-reinjection

2.
3.
  
Actual results:
BSOD while booting


Expected results:
boot normally


Additional info:
Comment 2 Cao, Chen 2010-07-27 23:47:25 EDT
$ rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.99.el6.x86_64

$ uname -r
2.6.32-52.el6.x86_64
Comment 3 Cao, Chen 2010-07-27 23:49:10 EDT
Created attachment 434901 [details]
Windows2008 virtio BSOD while booting
Comment 4 RHEL Product and Program Management 2010-07-27 23:57:34 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Vadim Rozenfeld 2010-07-28 00:48:03 EDT
(In reply to comment #3)
> Created an attachment (id=434901) [details]
> Windows2008 virtio BSOD while booting    

Please post the relevant dump file.
Thanks,
Vadim
Comment 6 Cao, Chen 2010-07-28 05:07:31 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > Created an attachment (id=434901) [details] [details]
> > Windows2008 virtio BSOD while booting    
> 
> Please post the relevant dump file.
> Thanks,
> Vadim    

tried a few times but cannot reproduce, on both
$ rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.99.el6.x86_64

$ uname -r
2.6.32-52.el6.x86_64    

and 
$ rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.104.el6.x86_64

$ uname -r
2.6.32-54.el6.x86_64
.

beside i found my block driver version is:
4.5.0.41217
date: 12/30/2009

and when i try to update it by point the target dir to 1.1.8-0,
windows says that it is already the newest driver.
Comment 7 Vadim Rozenfeld 2010-07-28 05:19:41 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #3)
> > > Created an attachment (id=434901) [details] [details] [details]
> > > Windows2008 virtio BSOD while booting    
> > 
> > Please post the relevant dump file.
> > Thanks,
> > Vadim    
> 
> tried a few times but cannot reproduce, on both
> $ rpm -q qemu-kvm
> qemu-kvm-0.12.1.2-2.99.el6.x86_64
> 
> $ uname -r
> 2.6.32-52.el6.x86_64    
> 
> and 
> $ rpm -q qemu-kvm
> qemu-kvm-0.12.1.2-2.104.el6.x86_64
> 
> $ uname -r
> 2.6.32-54.el6.x86_64
> .
> 
> beside i found my block driver version is:
> 4.5.0.41217
> date: 12/30/2009
> 
> and when i try to update it by point the target dir to 1.1.8-0,
> windows says that it is already the newest driver.    

Thank you, Cao.
The update problem looks very strange. Can you try a fresh install with a block driver from 1.1.8-0?
Thanks,
Vadim.
Comment 8 Cao, Chen 2010-07-29 03:29:59 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > (In reply to comment #3)
> > > > Created an attachment (id=434901) [details] [details] [details] [details]
> > > > Windows2008 virtio BSOD while booting    
> > > 
> > > Please post the relevant dump file.
> > > Thanks,
> > > Vadim    
> > 
> > tried a few times but cannot reproduce, on both
> > $ rpm -q qemu-kvm
[snip]
> > beside i found my block driver version is:
> > 4.5.0.41217
> > date: 12/30/2009
> > 
> > and when i try to update it by point the target dir to 1.1.8-0,
> > windows says that it is already the newest driver.    
> 
> Thank you, Cao.
> The update problem looks very strange. Can you try a fresh install with a block
> driver from 1.1.8-0?
> Thanks,
> Vadim.    

Vadim,

I have installed a fresh guest with 1.1.8-0 driver, the guest can boot
successfully. so i think there is no such bug in the new driver.

besides, i have found that when updating the driver, the newest driver does
be installed, but the guest still the old one, rather than the newer.

there is a bug for the update problem, BZ619010,
though it is about the nic driver.

so i think we can close this bug as NOTABUG or DUPLICATE to BZ 619010.

Thanks,
Cao, Chen
Comment 9 Vadim Rozenfeld 2010-07-29 03:42:16 EDT
Thank you, Cao.
If you can close this bug, please do it.

Regards,
Vadim.
Comment 10 Cao, Chen 2010-07-29 03:48:40 EDT
closing as https://bugzilla.redhat.com/show_bug.cgi?id=618914#c8

Note You need to log in before you can comment on or make changes to this bug.