Bug 618934 - The echo's man page in Japanese doesn't describe '\e' and '\xHH' for the option -e.
The echo's man page in Japanese doesn't describe '\e' and '\xHH' for the opti...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-ja (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Akira TAGOH
QE Internationalization Bugs
:
Depends On:
Blocks: 659134
  Show dependency treegraph
 
Reported: 2010-07-28 01:44 EDT by Shinji Kito
Modified: 2011-02-17 10:29 EST (History)
9 users (show)

See Also:
Fixed In Version: man-pages-ja-20100115-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: The old man page of echo(1) didn't contains descriptions of '\e' and '\xHH' syntax for -e option. Consequence: no descriptions of the above syntax in Japanese. Fix: Added the descriptions of '\e' and '\xHH' syntax for -e option. Result: The Japanese man page of echo(1) keeps up to date comparing with English version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 10:25:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0192 normal SHIPPED_LIVE man-pages-ja bug fix update 2011-02-02 10:25:17 EST

  None (edit)
Description Shinji Kito 2010-07-28 01:44:47 EDT
Description of problem:
The echo's man page in Japanese doesn't describe "\e" and "\xHH" for the option -e.
The echo's man-page in English says;

      If -e is in effect, the following sequences are recognized:

      \\     backslash

      \a     alert (BEL)

      \b     backspace

      \c     produce no further output

      \e     escape

      \f     form feed

      \n     new line

      \r     carriage return

      \t     horizontal tab

      \v     vertical tab

      \0NNN  byte with octal value NNN (1 to 3 digits)

      \xHH   byte with hexadecimal value HH (1 to 2 digits)

Since both "\e" and "\xHH" for "-e" are available on RHEL6, the man page
in Japanese should describe them according to the above description.
Could you please revise the man page in Japanese?

Version-Release number of selected component (if applicable):
RHEL 6 beta2 snapshot7
Related Package Version: man-pages-ja-20100115-2.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Just run the Japanese man page of echo.

  
Actual results:
Japanese man page for echo is missing '\e' and '\xHH' for the option -e.

Expected results:
Japanese man page for echo should have '\e' and '\xHH' for the option -e.

Additional info:
Comment 3 Akira TAGOH 2011-01-14 05:09:41 EST
Fixed in man-pages-ja-20100115-3.el6.
Comment 5 Florian Nadge 2011-01-19 12:22:20 EST
Please be so kind and add a few key words to the technical note of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 6 Florian Nadge 2011-01-19 12:22:21 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 7 Akira TAGOH 2011-01-21 07:22:22 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,11 @@
 Cause:
+The old man page of echo(1) didn't contains descriptions of '\e' and '\xHH' syntax for -e option.
 
 Consequence:
+no descriptions of the above syntax in Japanese.
 
 Fix:
+Added the descriptions of '\e' and '\xHH' syntax for -e option.
 
-Result:+Result:
+The Japanese man page of echo(1) keeps up to date comparing with English version.
Comment 9 errata-xmlrpc 2011-02-02 10:25:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0192.html

Note You need to log in before you can comment on or make changes to this bug.