Bug 618963 - Satellite 5.3: search returns confusing results
Satellite 5.3: search returns confusing results
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 04:14 EDT by Xixi
Modified: 2011-01-07 03:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 02:54:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2010-07-28 04:14:42 EDT
Description of problem:
When searching in RHN Satellite 5.3 for a server name, customer gets back lots of completely unrelated results. Similarly with packages.

Quoting customer:
"Under the previous version of the Sat this would return, either 0 or 1 matches.  Now I get multiples for something that I would expect is a unique identification.

In general, I would say that getting an exact or substring matches are reasonable but getting unrelated systems that happen to be similar named is now.  If there are no matches then broadening to partial matches may be useful, but getting back to the prior functionality is highly preferable to the kind of searches we do.  I would even go so far as use the term regression to describe this issue."

The core of the issue is that with the new search implementation with n-grams, instead of either exact match or nothing, multiple results are returned, with the exact matches highlighted in bold while the others (with lower scores) are not - for example searching for system ID 1000011801, the exact match is highlighted, whereas the others such as 1000011800 are also included in results, just not highlighted.  This can be confusing to the user, especially in cases where there's no exact match (like search for package "asdf") - seeing the non-bold results themselves seems to indicate they're matches.

Would it be possible to add a configuration option somewhere to only display the matching results (the ones in bold) and not the other, similar results?  
There does not appear to be a possible configuration for search tuning to do this.

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Searching for anything to illustrate the issue summary. But for example, search for a system by profile name, search for a system by ID, or search for a package by name. For both existing and non-existing system/pkgs.

Actual results:
Seems to match anything that has a string a few characters close. For example lfvsfcp20003 seems to match any profile with lfvsfcp200[xx], ID 1000011800 will match for search for 1000011801, and searching for 'asdf' will include xpdf and gpdf in results.

Expected results:
Similar to previous versions of Satellite, either the exact match turns up or it should say no results. Add a configuration option or documented search configuration to have it only display the exact match and not the others?  

Additional info:

Note You need to log in before you can comment on or make changes to this bug.