Bug 61897 - /usr/share/openldap/migrate_all_offline.sh parses /etc/services incorrectly.
/usr/share/openldap/migrate_all_offline.sh parses /etc/services incorrectly.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jay Fenlason
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-25 14:04 EST by Wouter Liefting
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 11:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wouter Liefting 2002-03-25 14:04:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)

Description of problem:
NOTE: THIS IS ABOUT SKIPJACK, NOT THE STABLE 7.2! (Bugzilla did not allow me to select Skipjack!)

/usr/share/openldap/migration/migrate_all_offline.sh fails because it parses the badly formatted line 310 in /etc/services incorrectly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure OpenLDAP server /etc/openldap/slapd.conf
2.cd /usr/share/openldap/migration
3../migrate_all_offline.sh
	

Actual Results:  slapadd: could not parse entry (line 4818).


Expected Results:  No error.

Additional info:

Looking at line 4818 in /tmp/nis.ldif.something revealed that this was in between the two bvcontrol services from /etc/services. Taking this line out 
solved the problem.
Comment 1 Bill Nottingham 2006-08-07 14:27:22 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 11:55:14 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.