Bug 619040 - Unable to add new entry to /etc/fstab
Summary: Unable to add new entry to /etc/fstab
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Keywords:
: 621139 (view as bug list)
Depends On: 618207
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-28 12:39 UTC by Marek Grac
Modified: 2016-04-26 13:34 UTC (History)
13 users (show)

Fixed In Version: system-config-lvm-1.1.12-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 618207
Environment:
Last Closed: 2010-11-10 21:42:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marek Grac 2010-07-28 12:39:06 UTC
+++ This bug was initially created as a clone of Bug #618207 +++

Description of problem:
When I try to create new LV and check "mount when rebooted" option and fill in mount point text field, I get this traceback:

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/InputController.py", line 656, in on_new_lv
    if dlg.run() == False:
  File "/usr/share/system-config-lvm/InputController.py", line 1351, in run
    if self.apply() == True:
  File "/usr/share/system-config-lvm/InputController.py", line 2041, in apply
    Fstab.add(None, lv_path, mountpoint_new, filesys_new.fsname)
  File "/usr/share/system-config-lvm/Fstab.py", line 27, in add
    fstab = __remove_and_replace(dev_path_old, line)
  File "/usr/share/system-config-lvm/Fstab.py", line 43, in __remove_and_replace
    paths = get_all_paths(mnt_device)
  File "/usr/share/system-config-lvm/Fstab.py", line 114, in get_all_paths
    follow_links_to_target(dev_path, paths)
  File "/usr/share/system-config-lvm/utilities.py", line 6, in follow_links_to_target
    o, s = execWithCaptureStatus('/bin/readlink', ['/bin/readlink', '-e', path])
  File "/usr/share/system-config-lvm/execute.py", line 15, in execWithCaptureStatus
    res = execWithCaptureErrorStatus(bin, args)
  File "/usr/share/system-config-lvm/execute.py", line 22, in execWithCaptureErrorStatus
    command = command + ' ' + arg
TypeError: cannot concatenate 'str' and 'NoneType' objects

The dialog then stays stuck and must be closed with titlebar close button. The LV is created, filesystem is created, but /etc/fstab is not modified and filesystem is not mounted.

Version-Release number of selected component (if applicable):
system-config-lvm-1.1.14-2.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1. Hit Create new LV
2. Select name, size, filesystem, select "mount when rebooted", fill in mount point
3. Hit OK

Comment 5 Marek Grac 2010-08-04 13:06:34 UTC
*** Bug 621139 has been marked as a duplicate of this bug. ***

Comment 7 releng-rhel@redhat.com 2010-11-10 21:42:54 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.