Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619043 - ypbind fails to bind to domain with "broadcast"
ypbind fails to bind to domain with "broadcast"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypbind (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Karel Klíč
qe-baseos-daemons
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 08:45 EDT by Rik van Riel
Modified: 2013-03-03 18:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 10:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2010-07-28 08:45:07 EDT
Description of problem:

# cat /etc/yp.conf 
# /etc/yp.conf - ypbind configuration file
# Valid entries are
...
domain surriel.com broadcast

The above yp.conf works fine for RHEL5 and Fedora 12, on the same network with the same NIS server.  However, RHEL6 ypbind fails to bind to the domain.

# service ypbind start
Starting NIS service:                                      [  OK  ]
Binding NIS service: ......................                [FAILED]
Shutting down NIS service:                                 [  OK  ]

Version-Release number of selected component (if applicable):

ypbind-1.20.4-29.el6.x86_64

How reproducible:

Have "broadcast" as the server.  Try to start ypbind and watch it fail.
Comment 2 RHEL Product and Program Management 2010-07-28 09:17:45 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Karel Klíč 2010-07-28 09:58:10 EDT
Hello,

it works well here, so I need more information about what is happening on your computer.

Please try to run ypbind manually in the debug mode:

$ sudo service ypbind stop
$ sudo ypbind -d

and attach its output to this bug. Make sure that both SELinux and firewall are turned off (something like 'setenforce 0; service iptables stop') during this test.

If you have access to the yp server, please run the ypserv manually in the debug mode and consider attaching its output to this bug:

$ sudo service ypserv stop
$ sudo ypserv -d

Thank you.
Comment 4 RHEL Product and Program Management 2010-07-28 10:17:42 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Rik van Riel 2010-07-28 10:59:02 EDT
Looks like iptables is indeed the problem.  Without broadcast things work fine with iptables.  With iptables on, broadcast never gets an answer from the server. With iptables off, broadcast NIS works.

For some reason, the INPUT rules did not show up in "iptables -L" after the kvm iptables rules were added?

Anyway, this is not a ypbind bug.

Note You need to log in before you can comment on or make changes to this bug.