Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 619060 - packaging error - two packages conflict
packaging error - two packages conflict
Status: CLOSED DUPLICATE of bug 618537
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 09:31 EDT by Valdis Kletnieks
Modified: 2014-06-18 04:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 10:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2010-07-28 09:31:32 EDT
Description of problem:

Not sure if it's upstart or systemd problem...

Trying to do a 'yum update upstart', I get:

#  yum update upstart
Loaded plugins: auto-update-debuginfo, changelog, downloadonly, presto, refresh-packagekit, refresh-updatesd
Found 57 installed debuginfo package(s)
Enabling rawhide-debuginfo: Fedora - Rawhide - Debug
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package systemd-sysvinit.x86_64 0:4-3.fc14 set to be installed
--> Processing Dependency: systemd = 4-3.fc14 for package: systemd-sysvinit-4-3.fc14.x86_64
--> Processing Dependency: upstart >= 0.6.5-6.fc14 for package: systemd-sysvinit-4-3.fc14.x86_64
--> Running transaction check
---> Package systemd.x86_64 0:4-3.fc14 set to be installed
---> Package upstart.x86_64 0:0.6.5-7.fc14 set to be updated
--> Processing Dependency: sysvinit-userspace for package: upstart-0.6.5-7.fc14.x86_64
--> Running transaction check
---> Package upstart-sysvinit.x86_64 0:0.6.5-7.fc14 set to be installed
--> Processing Conflict: systemd-sysvinit-4-3.fc14.x86_64 conflicts upstart-sysvinit
--> Processing Conflict: upstart-sysvinit-0.6.5-7.fc14.x86_64 conflicts systemd-sysvinit
--> Finished Dependency Resolution
Error: systemd-sysvinit conflicts with upstart-sysvinit
Error: upstart-sysvinit conflicts with systemd-sysvinit
 You could try using --skip-broken to work around the problem

The sad thing is that of all the packages mentioned, only the current upstart is actually installed:

# rpm -q upstart systemd systemd-sysvinit sysvinit-userspace upstart-sysvinit systemd-sysvinit
upstart-0.6.5-5.fc14.x86_64
package systemd is not installed
package systemd-sysvinit is not installed
package sysvinit-userspace is not installed
package upstart-sysvinit is not installed
package systemd-sysvinit is not installed

Looks like a pissing match over whether upstart or systemd owns the -sysvinit part.  Feel free to close if the urination has stopped and my Rawhide mirror is just a bit slow updating...

Version-Release number of selected component (if applicable):
upstart.x86_64 0:0.6.5-7.fc14

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Petr Lautrbach 2010-07-28 10:36:57 EDT
It's related to making systemd as default init.

There are two possibilities:

1. avoid installing systemd-sysvinit with 'yum install upstart-sysvinit' which should update also upstart

2. wait until fixed systemd-sysvinit-4-4 (#618537) reach rawhide repo and update

*** This bug has been marked as a duplicate of bug 618537 ***

Note You need to log in before you can comment on or make changes to this bug.