Bug 619150 - faillog executes during argument parsing
Summary: faillog executes during argument parsing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: shadow-utils   
(Show other bugs)
Version: 5.5
Hardware: All Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Peter Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 690831
TreeView+ depends on / blocked
 
Reported: 2010-07-28 17:25 UTC by Martin Poole
Modified: 2018-11-14 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 06:16:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to place execution after argument parsing (2.66 KB, patch)
2010-07-28 17:29 UTC, Martin Poole
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0244 normal SHIPPED_LIVE shadow-utils bug fix update 2012-02-20 15:07:21 UTC

Description Martin Poole 2010-07-28 17:25:06 UTC
Description of problem:

faillog executes options as they are parsed rather than once they have all been gathered

Thus

  faillog -r -u 1234

will reset the fail counter for all users rather than just the named user, whereas

  faillog -u 1234 -r

will reset for just the one user.

Upstream code has rework the code to put the execution of function after the parsing of arguments has completed.

Version-Release number of selected component (if applicable):

shadow-utils-4.0.17-15.el5

Comment 1 Martin Poole 2010-07-28 17:29:46 UTC
Created attachment 435089 [details]
patch to place execution after argument parsing

Comment 7 errata-xmlrpc 2012-02-21 06:16:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0244.html


Note You need to log in before you can comment on or make changes to this bug.