Bug 619153 - no input devices after booting up 2.6.32-53.el6
no input devices after booting up 2.6.32-53.el6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Harald Hoyer
Release Test Team
: Regression
: 619374 619708 620812 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 13:32 EDT by Jay Turner
Modified: 2015-01-07 19:17 EST (History)
13 users (show)

See Also:
Fixed In Version: dracut-004-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 09:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2010-07-28 13:32:58 EDT
Description of problem:
X completely freezes at GDM after booting up 2.6.32-53.el6.x86_64 on a machine running the nouveau driver (GeForce 9600M GT.)  System boots fine, no messages that I've been able to locate to this point, but once GDM starts up, the display is completely frozen.

Version-Release number of selected component (if applicable):
kernel-2.6.32-53.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-8.20100423git13c1043.el6.x86_64

How reproducible:
Always.  Dropping back to -52.el6 and everything works fine again

Steps to Reproduce:
1. Boot up -53.el6.x86_64 on a nouveau-enabled system
2.
3.
  
Actual results:
Display freeze

Expected results:


Additional info:
Seeing this on another nouveau machine as well (GeForce GTX 285)
Comment 1 Jay Turner 2010-07-28 14:33:36 EDT
Additional note.  Although access via ssh is fine, the directly attached keyboard and mouse are completely frozen as well (unable to cycle the capslock/numlock, etc.)
Comment 2 Linda Wang 2010-07-28 14:46:40 EDT
-53 has the following patches pull in..

- [drm] nouveau: cleanup connector/encoder creation (Ben Skeggs) [612402]
- [drm] nouveau: move LVDS detection back to connector detect() time (Ben Skeggs) [612402]
- [drm] nouveau: fix race condition when under memory pressure (Ben Skeggs) [602663]
Comment 3 Jay Turner 2010-07-28 15:09:50 EDT
The 3rd patch listed above (602663) was independently verified in a scratch-build kernel.  Just as a data point.
Comment 4 Ben Skeggs 2010-07-28 18:25:43 EDT
All 3 patches were actually present in the scratch build mentioned.

Can you provide dmesg and Xorg.0.log, hopefully they'll reveal something.
Comment 5 Dave Airlie 2010-07-28 23:34:22 EDT
this isn't a nouveau bug,

something has broken hal and input devices.

lshal | grep x11

from a working kernel and non-working kernel are different,

restarting hal fixes the problem, I suspect 

kernel
dracut
hal.
Comment 6 Dave Airlie 2010-07-28 23:40:12 EDT
cc'd Harald and Richard Hughes.
Comment 7 Ray Strode [halfline] 2010-07-29 00:05:06 EDT
This may be related to the fix for bug 617526
Comment 8 Ray Strode [halfline] 2010-07-29 00:19:21 EDT
airlied just confirmed this problem only happens if you rebuild the initrd after having dracut-004-27 installed.  Rebuilding the initrd with any other version of dracut works.  Moving to dracut...
Comment 9 Dave Airlie 2010-07-29 00:24:14 EDT
if I remove the umask in the 0196 patch in dracut it all seems to work okay.
Comment 10 Harald Hoyer 2010-07-29 05:14:09 EDT
dracut-004-28.el6
Comment 12 Harald Hoyer 2010-07-29 05:34:43 EDT
I would be very interested, which files were affected by the umask. Can you find that out for me?
Comment 13 Dave Airlie 2010-07-29 07:39:56 EDT
I'll try and reproduce, at a guess some files hal was going to read.
Comment 14 Dave Airlie 2010-07-29 08:15:00 EDT
*** Bug 619374 has been marked as a duplicate of this bug. ***
Comment 15 Jeff Layton 2010-07-29 08:26:32 EDT
Confirmed. Installing new dracut package and rebuilding the initramfs fixed the issue for me.
Comment 16 Jay Turner 2010-07-29 08:41:45 EDT
+1 for comment 15.
Comment 17 Harald Hoyer 2010-07-29 12:18:00 EDT
regression from bugfix of bug 617526
Comment 19 Phil Knirsch 2010-08-02 09:00:56 EDT
*** Bug 619708 has been marked as a duplicate of this bug. ***
Comment 21 Harald Hoyer 2010-08-05 02:51:49 EDT
*** Bug 620812 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.