Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619166 - QMF: bindPackage() + bindClass() does not work with V2 routing keys.
QMF: bindPackage() + bindClass() does not work with V2 routing keys.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
beta
All Linux
low Severity high
: 1.3
: ---
Assigned To: Ken Giusti
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 14:31 EDT by Ken Giusti
Modified: 2011-08-12 12:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-22 07:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Giusti 2010-07-28 14:31:43 EDT
Description of problem:

Console's cannot filter data and events using the bindPackage()/bindClass() api.  This is due to the agent using a routing key that does not contain any package or class information.  Currently the agent sends all data indications using the key "agent.ind.data", and all event indications using key "agent.ind.event"
Comment 1 Ken Giusti 2010-08-01 13:22:59 EDT
See the description of the api implementation in the following upstream bug:
https://issues.apache.org/jira/browse/QPID-2782
Comment 2 Ken Giusti 2010-08-01 21:49:37 EDT
Checked in upstream:

Committed revision 981277.

Note You need to log in before you can comment on or make changes to this bug.