Bug 619172 - gthumb cannot import images any more
gthumb cannot import images any more
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 14:49 EDT by Dirk Hoffmann
Modified: 2010-09-11 05:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: gthumb-2.10.12-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 05:00:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 625698 None None None Never
Launchpad 486617 None None None Never

  None (edit)
Description Dirk Hoffmann 2010-07-28 14:49:02 EDT
Description of problem:
gthumb had a problem in the past, about six months ago: It did not recognise USB-mounted photo media (SD or CF card reader). The window just stayed empty, no way to get images scanned from the media.
That was solved with some package releases about 2 months ago.
As I do not use it too frequently on my laptop (DELL latitude D520), I only noticed this week, that it seems to be broken again, but in a different way:

gthumb correctly recognises the media (SD card in this case) and displays all files (images and movies). I can (select the wanted images and) click on "Import"; button flashes, progress bar appears. But nothing else happens. The interfaces stays reactive; I can select other images and scroll, click "Import" again. 

Launching from commandline gives no errors except something with invalid value for thread priority value. Options (rotate, delete, ...) do not matter; same result!

Version-Release number of selected component (if applicable):
gthumb-2.10.11-9.fc12.i686

How reproducible:
see above, with the latest updates for F12

Actual results:
No import possible

Expected results:
Import possible.

Additional info:
I _suspect_ this problem to have appeared with the glibc library update, the only "big" update of packages related to this, but there was also a libexif update in between. I cannot simply revert these packages, so it remains a suspicion, not more.
Comment 1 John Gotts 2010-08-31 18:03:25 EDT
Here is the problem.  You have movies on your memory card!

Run gthumb-importer from a terminal and click Import.  You will see the following error message:

(gthumb:6553): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

Now change to /media/whatever your automount directory name is.

Temporarily move all movies to a safe spot off of the memory card, for example ~/mov

Run gthumb-importer and click Import.  Voila!  It works.

Something broke in the version of gthumb shipping with Fedora 12.  Fedora 11 and earlier correctly ignored non JPEGs.

This might be a one-liner for Christian to fix.
Comment 2 Dirk Hoffmann 2010-09-01 03:27:36 EDT
(In reply to comment #1)
> Here is the problem.  You have movies on your memory card!

Thank you for the hint. I will check later, but indeed there are movies on the card. That may explain why I beleive that it worked some time with the F12 distribution earlier (probably with one of my cards that does not contain movies). 

> (gthumb:6553): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion
> `percentage >= 0 && percentage <= 1.0' failed

I confirm that this message appears, but could not connect it to the problem. 

> This might be a one-liner for Christian to fix.

I hope so :-)
Comment 3 Christian Krause 2010-09-01 18:03:36 EDT
Fortunately there was already an upstream bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=625698
and also a patch to fix the issue.

Basically all time when for at least one file within the list no preview could be generated gthumb did not import any files. In your case it was the video for which libgphoto2 could not generate a preview image.

An update for Fedora 12 is on its way.

With the newer gthumb in rawhide and F13 (2.11.91) I could not reproduce the issue - no actions necessary in these Fedora branches.
Comment 4 Fedora Update System 2010-09-01 18:06:24 EDT
gthumb-2.10.12-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/gthumb-2.10.12-2.fc12
Comment 5 John Gotts 2010-09-02 13:44:44 EDT
I have verified your fix to work.

Thanks for looking into the problem!

John
Comment 6 Dirk Hoffmann 2010-09-02 16:21:13 EDT
(In reply to comment #4)
> gthumb-2.10.12-2.fc12 has been submitted as an update for Fedora 12.
> https://admin.fedoraproject.org/updates/gthumb-2.10.12-2.fc12

I confirm that both work

 - the workaround with copying movies or unreadable files "by hand"

 - the update 2.10.12-2 works also with movies on the card. 

Unfortunately the update is not yet in the fedora (yum) repository. Can John's and my statement be used to validate it?
Comment 7 Christian Krause 2010-09-02 16:43:58 EDT
Good to hear that it works!

It will take some time until the update reaches updates-testing and later updates. Since koji is capable to set the bug status correctly (and populating some information about the package where it is fixed etc.) I'll set the bug status back to MODIFIED. ;-)
Comment 8 Fedora Update System 2010-09-02 16:46:31 EDT
gthumb-2.10.12-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gthumb'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gthumb-2.10.12-2.fc12
Comment 9 Fedora Update System 2010-09-11 05:00:05 EDT
gthumb-2.10.12-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.