Bug 61925 - PAM/SU behaviour is worrying with regards to root user
PAM/SU behaviour is worrying with regards to root user
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sh-utils (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On: 62432
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-25 19:03 EST by Alan Cox
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 11:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-03-25 19:03:23 EST
edit /etc/pam.d/su
Comment out the entry for auth sufficient pam_rootok

(Not wanting root to be able to su - this makes sense with stuff like RSBAC)

su someuser
[no password is requested]
%

I'd really expect this to fail the su
Comment 1 Bill Nottingham 2002-03-26 14:46:33 EST
It could be possible that the check for root is in su itself and not in pam.
Comment 2 Bill Nottingham 2002-03-26 14:47:59 EST
In fact, it is...
Comment 3 Bernhard Rosenkraenzer 2002-03-27 12:28:23 EST
Fixed in -12
Comment 4 Bernhard Rosenkraenzer 2002-04-02 05:37:25 EST
Reverted the fix because it introduces a much much worse problem (Bug #62432).
Comment 5 Bernhard Rosenkraenzer 2002-04-02 05:43:38 EST
Setting to NEEDINFO for resolution of #62432
Comment 6 Bernhard Rosenkraenzer 2002-04-08 11:52:17 EDT
Fixed in -14

Note You need to log in before you can comment on or make changes to this bug.