Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619402 - updated RHUA does not pull from hosted cds
updated RHUA does not pull from hosted cds
Status: CLOSED CURRENTRELEASE
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 09:23 EDT by wes hayutin
Modified: 2012-05-31 08:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 08:53:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-07-29 09:23:59 EDT
[root@ip-10-161-53-10 rhua]# rhui-tools 
        Select the component to be configured:
          1 - RHUA
          2 - CDS
          3 - Client
          4 - Entitlement Certificates
        Selection:  1
        
                                   -= RHUA Configuration =- 
        
        The following questions are used to configure the RHUA instance.
        
        The host names of the CDS instances that should be managed by this RHUA
        are
        required in this configuration.
        
        Unless otherwise specified, all fields are required.
        
        Local directory in which the RHUA configuration files generated by this
        tool
        should be stored (if this directory does not exist, it will be created):
        /tmp/rhua
        
        Directory on the RHUA where packages synchronized to the RHUA will be
        stored on disk.
        If this directory does not already exist, it will be created during the
        RHUA configuration:
        /mnt/content
        
        Directory on the CDS where the RHUA will upload packages. This value
        should be the
        same as what is specified in the CDS configuration:
        /mnt/content
        
        Full path to the content certificate the RHUA will use when downloading
        packages from Red Hat:
        /root/akamai_debug_certificates/nimbus_cloude_debug.crt
        
        Full path to the content certificate's private key:
        /root/akamai_debug_certificates/nimbus_cloude_debug.key
        
        Full path to the SSH key that will be used to connect to CDS instances:
        /root/nimbus-rpms/wes-us-westkey.pem
        
        Enter the host names of all CDS instances the RHUA will use, one per
        line.
        To finish inputting instances, enter a blank line.
        
        -> ec2-184-72-12-63.us-west-1.compute.amazonaws.com
        -> ec2-204-236-186-215.us-west-1.compute.amazonaws.com
        -> 
        
        Should monitoring features be enabled on the RHUA? If yes, the
        entitlement
        certificates to use to connect the CDS will be specified now. (y/n)
        y
        
        Full path to the CA certificate used to sign the entitlement
        certificates.
        /tmp/entitlement-cert/entitlement-cert.crt
        
        Full path to the entitlement certificates' private key.
        /tmp/entitlement-cert/entitlement-key.pem
        
        Enter the full paths to each entitlement certificate, one per line. The
        certificate
        should be named the same as the channel name for which entitlements are
        granted
        and end with .pem.
        To finish inputting certificates, enter a blank line.
        
        -> /root/nimbus-rpms/ssl/build/client-rhel32.crt
        -> /root/nimbus-rpms/ssl/build/client-rhel64.crt
        -> 
        
        RPM creation successful
        
        RHUA configuration files can be found
        at /tmp/rhua/rhua/tmp/rh-rhua-config-0.1
        RPMs can be found at /tmp/rhua/rhua/build/RPMS
        
        [root@ip-10-161-53-10 rhua]# rpm -e rh-rhua-config
        [root@ip-10-161-53-10 rhua]# rpm
        -Uvh /tmp/rhua/rhua/build/RPMS/noarch/rh-rhua-config-0.1-1.noarch.rpm 
        Preparing...                ###########################################
        [100%]
           1:rh-rhua-config         ###########################################
        [100%]
        
        [root@ip-10-161-53-10 rhua]# rhua start
        ========================================
        RHUA Start
        
        Running RHUA system start
        Package directory [/mnt/content] already exists, nothing to do
        Synchronizing content
        Synchronizing channel list to base [/mnt/content]
        Synchronizing channel [rhel-i386-server-5] and creating repo
        Traceback (most recent call last):
          File "/usr/bin/rhua", line 21, in ?
            rhua.cli.main(sys.argv)
          File "/usr/lib/python2.4/site-packages/rhua/cli.py", line 102, in main
            func(options, *args[2:])
          File "/usr/lib/python2.4/site-packages/rhua/rhua.py", line 69, in
        start
            num_packages = package_ops.sync(options)
          File "/usr/lib/python2.4/site-packages/rhua/package_ops.py", line 55,
        in sync
            report = g.fetchYumRepo(basepath=channel_path)
          File "/usr/lib/python2.4/site-packages/grinder/RepoFetch.py", line
        179, in fetchYumRepo
            self.yumFetch.getRepoData()
          File "/usr/lib/python2.4/site-packages/grinder/RepoFetch.py", line
        103, in getRepoData
            for ftype in self.repo.repoXML.fileTypes():
          File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1392, in
        <lambda>
            repoXML = property(fget=lambda self: self._getRepoXML(),
          File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1388, in
        _getRepoXML
            raise Errors.RepoError, msg
        yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml)
        for repository: rhel-i386-server-5. Please verify its path and try again
        
        [root@ip-10-161-53-10 akamai_debug_certificates]# ls
        cdn.redhat.com-chain.crt  nimbus_cloude_debug.crt
        nimbus_cloude_debug.csr  nimbus_cloude_debug.key  os  README.txt
        repomd.xml  yum-validcert.conf
        [root@ip-10-161-53-10 akamai_debug_certificates]# cat README.txt 
        Testing:
        
        wget --certificate=nimbus_cloude_debug.crt
        --private-key=nimbus_cloude_debug.key
        --ca-certificate=cdn.redhat.com-chain.crt
        https://cdn.redhat.com/content/dist/rhel/server/5Server/i386/rhui/1.1/os
        
        yum -c yum-validcert.conf search foo
        [root@ip-10-161-53-10 akamai_debug_certificates]# wget
        --certificate=nimbus_cloude_debug.crt
        --private-key=nimbus_cloude_debug.key
        --ca-certificate=cdn.redhat.com-chain.crt
        https://cdn.redhat.com/content/dist/rhel/server/5Server/i386/rhui/1.1/os
        --2010-07-28 21:02:13--
        https://cdn.redhat.com/content/dist/rhel/server/5Server/i386/rhui/1.1/os
        Resolving cdn.redhat.com... 96.16.200.251
        Connecting to cdn.redhat.com|96.16.200.251|:443... connected.
        HTTP request sent, awaiting response... 200 OK
        Length: 2924 (2.9K) [text/html]
        Saving to: `os.1'
        
        100%[===========================================================================================================================>] 2,924       --.-K/s   in 0s      
        
        2010-07-28 21:02:13 (349 MB/s) - `os.1' saved [2924/2924]
        
        [root@ip-10-161-53-10 akamai_debug_certificates]# rhua start
        ========================================
        RHUA Start
        
        Running RHUA system start
        Package directory [/mnt/content] already exists, nothing to do
        Synchronizing content
        Synchronizing channel list to base [/mnt/content]
        Synchronizing channel [rhel-i386-server-5] and creating repo
        Traceback (most recent call last):
          File "/usr/bin/rhua", line 21, in ?
            rhua.cli.main(sys.argv)
          File "/usr/lib/python2.4/site-packages/rhua/cli.py", line 102, in main
            func(options, *args[2:])
          File "/usr/lib/python2.4/site-packages/rhua/rhua.py", line 69, in
        start
            num_packages = package_ops.sync(options)
          File "/usr/lib/python2.4/site-packages/rhua/package_ops.py", line 55,
        in sync
            report = g.fetchYumRepo(basepath=channel_path)
          File "/usr/lib/python2.4/site-packages/grinder/RepoFetch.py", line
        179, in fetchYumRepo
            self.yumFetch.getRepoData()
          File "/usr/lib/python2.4/site-packages/grinder/RepoFetch.py", line
        103, in getRepoData
            for ftype in self.repo.repoXML.fileTypes():
          File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1392, in
        <lambda>
            repoXML = property(fget=lambda self: self._getRepoXML(),
          File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1388, in
        _getRepoXML
            raise Errors.RepoError, msg
        yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml)
        for repository: rhel-i386-server-5. Please verify its path and try again
        [root@ip-10-161-53-10 akamai_debug_certificates]#
Comment 1 Jay Dobies 2010-07-29 09:26:57 EDT
commit	c79ee486a3fe4d99b70927bb2297f013239c1199
tree	a08fc556d32faec2dc96a14c5a10abc98684a742

The URL concatenation doesn't like a trailing slash on the hostname.

rhui/rhua/etc/rhua/rhua.yml
Comment 2 wes hayutin 2010-07-29 10:10:41 EDT
[root@ip-10-161-53-10 nimbus-rpms]# rhua start
========================================
RHUA Start

Running RHUA system start
Package directory [/mnt/content] already exists, nothing to do
Synchronizing content
Synchronizing channel list to base [/mnt/content]
Synchronizing channel [rhel-i386-server-5] and creating repo
Synchronized channel [rhel-i386-server-5] in [386] seconds
Synchronizing channel [rhel-x86_64-server-5] and creating repo
Traceback (most recent call last):
  File "/usr/bin/rhua", line 21, in ?
    rhua.cli.main(sys.argv)
  File "/usr/lib/python2.4/site-packages/rhua/cli.py", line 102, in main
    func(options, *args[2:])
  File "/usr/lib/python2.4/site-packages/rhua/rhua.py", line 69, in start
    num_packages = package_ops.sync(options)
  File "/usr/lib/python2.4/site-packages/rhua/package_ops.py", line 55, in sync
    report = g.fetchYumRepo(basepath=channel_path)
  File "/usr/lib/python2.4/site-packages/grinder/RepoFetch.py", line 179, in fetchYumRepo
    self.yumFetch.getRepoData()
  File "/usr/lib/python2.4/site-packages/grinder/RepoFetch.py", line 103, in getRepoData
    for ftype in self.repo.repoXML.fileTypes():
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1392, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1388, in _getRepoXML
    raise Errors.RepoError, msg
yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-5. Please verify its path and try again
[root@ip-10-161-53-10 nimbus-rpms]# rpm -q rh-rhua
rh-rhua-0.65-1.el5
[root@ip-10-161-53-10 nimbus-rpms]# rpm -q rh-rhui-tools
rh-rhui-tools-0.33-1.el5
[root@ip-10-161-53-10 nimbus-rpms]# cat /etc/rhua/rhua.yml
# Installation
install_config : '/etc/rhua/config.yml'

# Logging
log_level : 'debug'  # debug, info, warning, error, critical
log_rhua_file : '/var/log/rhua.log'
log_grinder_file : '/var/log/grinder.log'

# Package Synchronization
sync_url : 'https://cdn.redhat.com'
sync_ca_cert : '/etc/pki/content/hosted-ca.crt'
sync_cert : '/etc/pki/content/product/content-cert.crt'
sync_cert_key : '/etc/pki/content/content-cert-key.pem'
sync_threads : 10
sync_channels :
- { name : 'rhel-i386-server-5', url : 'content/dist/rhel/server/5Server/i386/os' }
- { name : 'rhel-x86_64-server-5', url : 'content/dist/rhel/server/5Server/x86_64/os' }

# Daemons
daemon_update_entry : '0 */4 * * * root /bin/bash --login -c "/usr/bin/rhua update" > /dev/null'
daemon_update_file : '/etc/cron.d/rhua_update.cron'
daemon_monitor_entry : '*/2 * * * * root /bin/bash --login -c "/usr/bin/rhua monitor" > /dev/null'
daemon_monitor_file : '/etc/cron.d/rhua_monitor.cron'

# RHUA Yum Entitlement
ent_ca_cert : '/etc/pki/rhua-test/ca.crt'
ent_cert_dir : '/etc/pki/rhua-test/product/'
ent_key : '/etc/pki/rhua-test/key.pem'
ent_repo_template : '/etc/rhua/cds-template.repo'

# Mirror List
mirror_dir : '/var/www/html/pub/'

# Monitoring
monitor_file : '/tmp/cloude-healthcheck'

# CDS Configuration
#   Package synchronization & hosting
cds_package_dest : '/mnt/content/'
cds_package_mount : '/var/www/cds'

#   SSL certificates and keys
cds_ssl_cert_dest : '/etc/pki/tls/certs/server.crt'
cds_ssl_key_dest : '/etc/pki/tls/private/server.key'
cds_ca_cert_dest : '/etc/pki/tls/certs/ca.crt'
cds_ca_chain_dest : '/etc/pki/tls/certs/chain.crt'

#   Apache configuration
cds_ssl_httpd_conf : '/etc/rhua/cds/ssl.conf'
cds_cds_ssl_conf : '/etc/rhua/cds/cds_ssl.conf'
cds_yum_ssl_conf : '/etc/rhua/cds/yum_ssl.conf'
cds_ssl_conf_dest : '/etc/httpd/conf.d'
Comment 3 wes hayutin 2010-07-29 10:33:22 EDT
k.. the issue is w/ the hosted cds .. it has not populated x86_64

<bleanhar> not that I know of
<bleanhar> what's the path?
<jdob> content/dist/rhel/server/5Server/x86_64/os
<bleanhar> yeah, that os dir is missing now
<bleanhar> dgregor: ping
<jdob> oh woot, so its actually not my bug? sweet
<jdob> weshay: ^
Comment 4 wes hayutin 2011-08-01 17:39:09 EDT
moving to release pending
Comment 5 wes hayutin 2012-05-31 08:53:26 EDT
closing out, product released

Note You need to log in before you can comment on or make changes to this bug.