Bug 61941 - HP Deskjet driver hpijs not working
Summary: HP Deskjet driver hpijs not working
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ghostscript   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-26 02:34 UTC by Gerry Tool
Modified: 2007-04-18 16:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 11:30:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerry Tool 2002-03-26 02:34:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
I can set my deskjet 970c up fine with gimp-print or cdj970 drivers, but the
hpijs driver will not work.  I want to use the duplex printing feature of this
driver - works in other distributions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.use printconf-gui
2.set up HP desket 970 printer with hpijs driver
3.Try to print a test page
	

Actual Results:  No test page printed - other drivers produce test page

Expected Results:  Test page should print.

Additional info:

Driver options display as expected, so driver is definitely present - i checked
that the hpijs package is installed.

Comment 1 Bernhard Rosenkraenzer 2002-03-27 17:01:00 UTC
Does it work if you use CUPS?

Comment 2 Manfred Hollstein 2002-03-27 17:06:09 UTC
FWIW, I had similar problems on my system as the OP described, both with LPRng
and with CUPS. I also ran gs manually to output directly to /dev/lp0, effectively
bypassing any printer spooling software, and failed when using the ijs/hpijs
driver.

Comment 3 Tim Waugh 2002-04-02 14:00:33 UTC
I think this might be because of an hpijs mismatch between foomatic and ghostscript.

Comment 4 Manfred Hollstein 2002-04-03 08:43:10 UTC
I doubt that foomatic plays a role here; as I wrote in my previous comment, I
ran ghostscript manually similarly like this:

  $ gs -sDEVICE=ijs -sIjsServer=hpijs -dIjsUseOutputFD \
       -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="DESKJET 990" \
       -r300 -dNOPAUSE -dSAFER -sOutputFile="/dev/lp0" file.ps -c quit

This command shouldn't involve foomatic/cups/lprng whatsoever. As a result,
nothing was printed.

I'm currently downloading the latest SKipjack updates and will try, if
hpijs-1.0.4 will solve the problem.

Comment 5 Tim Waugh 2002-04-03 11:30:36 UTC
Okay, my mistake, it's because of a mismatch between the IJS client (in
ghostscript) and /usr/bin/hpijs.

Expect ghostscript-6.52-7 to be the package that actually fixes this.

Comment 6 Tim Waugh 2002-04-04 14:49:03 UTC
You'll also need foomatic-1.1-0.20020313.3, which has the correct calling
convention for the hpijs client.

Comment 7 Manfred Hollstein 2002-04-05 13:21:52 UTC
I've just checked the following combination:

  - ghostscript-6.53-7
  - ghostscript-fonts-5.50-3
  - cups-drivers-hpijs-1.1-0.20020313.3
  - hpijs-1.0.4-7
  - foomatic-1.1-0.20020313.3
  - Omni-foomatic-0.5.1-3

Setting up a HP OfficeJet G85 using the cdj550 driver works, but using the hpijs
driver still doesn't work!

Invoking plain gs, effectively bypassing lpr, as documented in

  /usr/share/doc/hpijs-1.0.4/hpijs_readme.html

to print a postscript file directly to /dev/lp0 only results in ejecting an
*empty* page :-(

Comment 8 Tim Waugh 2002-04-05 13:25:40 UTC
Indeed: it's 6.52 you want, not 6.53.  The current ghostscript package is 6.52-8.

Comment 9 Manfred Hollstein 2002-04-05 13:31:47 UTC
And why is 6.53-7 included in the skipjack beta as of 0402.01 then?

Comment 10 Tim Waugh 2002-04-05 13:33:21 UTC
Because 6.52-7 was too late for it.


Note You need to log in before you can comment on or make changes to this bug.