Bug 61943 - Error when unmounting cdrom in GNOME
Error when unmounting cdrom in GNOME
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
David Lawrence
:
: 60902 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-25 21:53 EST by Jim Hayward
Modified: 2013-03-13 00:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 13:19:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Hayward 2002-03-25 21:53:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
When trying to unmount one of my cdrom drives I get this error message:

cannot open /etc/mtab.tmp (Invalid argument) - mtab not updated

The cdrom is unmounted because I can remove the cd, but in order to
remove the CD icon from the desktop I have to umount the cdrom again. Of course
I then get the message that the cdrom is not mounted, but the icon disappears. 


Version-Release number of selected component (if applicable):
magicdev-0.3.6-3

How reproducible:
Always

Steps to Reproduce:
1. insert cd in drive
2. nautilus will launch automatically
3. right click the cd icon on the screen and click: unmount volume or in a
console: umount /mnt/cdrom 
4. error message above is displayed


Actual Results:  Above error message is displayed

Expected Results:  cdrom unmounts without the error message

Additional info:
Comment 1 Jay Turner 2002-03-28 14:20:39 EST
I'm not able to replicate this in the lab using magicdev-0.3.6-3.  Can you
provide more details?  Is this the only CDROM drive on the system?  Also, what
does /etc/mtab look like?
Comment 2 Jim Hayward 2002-03-28 14:51:07 EST
I not sure if this is a magicdev problem or something else. I posted this
problem to the Skipjack mailing list and someone else confirmed they were having
the same problem.

$ rpm -q magicdev
magicdev-0.3.6-3

/etc/mtab before mounting cdrom
$ cat /etc/mtab
/dev/hda5 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda1 /boot ext3 rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda6 /home ext3 rw 0 0
/dev/hda7 /lfs ext3 rw 0 0
none /dev/shm tmpfs rw 0 0

/etc/mtab after mounting
$ cat /etc/mtab
/dev/hda5 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda1 /boot ext3 rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda6 /home ext3 rw 0 0
/dev/hda7 /lfs ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
/dev/cdrom /mnt/cdrom iso9660 ro,nosuid,nodev,user=jimh 0 0

In a console window:
$ umount /mnt/cdrom
cannot open /etc/mtab.tmp (Invalid argument) - mtab not updated

I get the same error above if I right click the cd icon and select unmount volume.

The cd IS now unmounted. CD icon is still on the screen.
$ ll /mnt/cdrom
total 0

but look at /etc/mtab still
$ cat /etc/mtab
/dev/hda5 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda1 /boot ext3 rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda6 /home ext3 rw 0 0
/dev/hda7 /lfs ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
/dev/cdrom /mnt/cdrom iso9660 ro,nosuid,nodev,user=jimh 0 0

If I issue another umount /mnt/cdrom
$ umount /mnt/cdrom
umount: /dev/cdrom: not mounted

The cd icon disappears from the screen and cat /etc/mtab doesn't show the cdrom
entry anymore
$ cat /etc/mtab
/dev/hda5 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda1 /boot ext3 rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda6 /home ext3 rw 0 0
/dev/hda7 /lfs ext3 rw 0 0
none /dev/shm tmpfs rw 0 0

There are 2 cd drives on the system.

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
kernel:         <Adaptec 2930CU SCSI adapter>
kernel:         aic7860: Ultra Single Channel A, SCSI Id=7, 3/253 SCBs
kernel: 
kernel:   Vendor: TEAC      Model: CD-ROM CD-532S    Rev: 1.0A
kernel:   Type:   CD-ROM                             ANSI SCSI revision: 02
kernel:   Vendor: PLEXTOR   Model: CD-R   PX-W1210S  Rev: 1.04
kernel:   Type:   CD-ROM                             ANSI SCSI revision: 02

This problem happens on both drives. They are mounted as /mnt/cdrom and /mnt/cdrom1

ll /dev/cdrom*
lrwxrwxrwx    1 root root 9 Feb 21 21:47 /dev/cdrom -> /dev/scd0
lrwxrwxrwx    1 root root 9 Feb 21 21:47 /dev/cdrom1 -> /dev/scd1

Anything further information I can provide you with?

Thanks
Comment 3 Joshua 2002-04-01 10:19:44 EST
I have the exact same situation except that I am using KDE, 2 cdrom drives both
error unmounting when trying to update mtab. A zero length, group writeable, 
mtab.tmp file, owner root and group user, is created on the first umount attempt.
The drive is unmounted but mtab is not updated, a second umount and mtab gets
updated but it results in an error that the drive is not mounted.
Comment 4 Jim Hayward 2002-04-08 11:35:19 EDT
This problem appears to be fixed in Skipjack beta2. I have so far been unable to
reproduce it in beta2. Thanks
Comment 5 Brent Fox 2002-04-09 11:26:02 EDT
josh, does your problem disappear with beta2?
Comment 6 Jeremy Katz 2002-04-10 18:22:04 EDT
*** Bug 60902 has been marked as a duplicate of this bug. ***
Comment 7 John (J5) Palmieri 2004-08-25 13:19:00 EDT
Seems to have been fixed in current releases.  Closing.

Note You need to log in before you can comment on or make changes to this bug.