Bug 619507 - No JSON object could be decoded... when trying to register with an invalid username or password
Summary: No JSON object could be decoded... when trying to register with an invalid u...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-29 17:29 UTC by John Sefler
Modified: 2018-12-10 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-10 15:37:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Sefler 2010-07-29 17:29:35 UTC
Description of problem:
# subscription-manager-cli register --username=fooooooo --password=barrrrr
No JSON object could be decoded


Actual Results:
No JSON object could be decoded


Expected Results:
Invalid username or password


Additional Info
This used to be the behavior


This is failing some automated tests

Comment 1 John Sefler 2010-07-29 17:37:43 UTC
Actually, I get the same error on valid users too, for example:

subscription-manager-cli register --username=epgy_bsears --password=redhat


Actual Results:
No JSON object could be decoded


Expected Results:
The user has been disabled, if this is a mistake, please contact customer service.

If my memory is correct, ^ used to be the expected results.

Comment 2 Justin Harris 2010-08-04 14:35:50 UTC
This has been fixed in master, and was due to incompatibilities when upgrading to the latest Resteasy release.  I reverted this back to the beta (previous) version and the message now reads 'Invalid username or password'.

Comment 3 wes hayutin 2010-08-10 14:18:42 UTC
[root@client02-rhel6-beta2 src]# ./subscription-manager-cli register --username=fooooooo --password=barrrrr --force
Invalid username or password

Comment 4 John Sefler 2011-05-04 14:40:45 UTC
Group move of VERIFIED Candlepin component bugs to RELEASE_PENDING

Comment 5 Bryan Kearney 2018-12-10 15:37:01 UTC
I am closing out some old bugs from 2015. So, closing these out as current release. If this is still an issue for me, please reach out.


Note You need to log in before you can comment on or make changes to this bug.