Bug 619522 - ksh is not in /usr/bin - only /bin
Summary: ksh is not in /usr/bin - only /bin
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords: Regression, RHELNAK
: 695434 871890 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-29 18:03 UTC by Alain D D Williams
Modified: 2018-11-30 20:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
ksh in Red Hat Enterprise Linux 6 no longer contains /usr/bin/ksh symbolic link to /bin/ksh. Some scripts may need to change their shebang.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 14:22:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 659658 None None None Never

Description Alain D D Williams 2010-07-29 18:03:03 UTC
Description of problem:

This is installed at /bin/ksh, it is/was commonly also found at /usr/bin/ksh. If a script starts:
#!/usr/bin/ksh
it will fail.
In RHel5 it was at both places.

Version-Release number of selected component (if applicable):

RHel6 beta

How reproducible:

Very


Additional info:

A symbolic link would fix it.

Comment 2 RHEL Product and Program Management 2010-07-29 18:27:36 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Denise Dumas 2010-07-30 14:22:52 UTC
We are planning to document this is Migration Guide and release notes. 

shells were intentionally moved out of /usr/bin

Comment 5 Alain D D Williams 2010-07-31 13:55:54 UTC
> shells were intentionally moved out of /usr/bin

I don't know if that is a good idea, at least not without leaving a symlink.

On many traditional unix systems (I am looking at an AIX one) ksh is in /usr/bin. The result of only having it in /bin will cause problems with portability of scripts between different Unix systems.

I have just checked a Debian squeeze/sid machine, I can see /usr/bin/ksh AND /bin/ksh --- so removing ksh from /usr/bin will cause portability problems between different Linux distros.

Please think again.

Comment 6 Scott Radvan 2010-08-01 22:02:23 UTC
note added to migration guide

Comment 7 Michal Hlavinka 2010-08-02 13:26:52 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
ksh in Red Hat Enterprise Linux 6 no longer contains /usr/bin/ksh symbolic link to /bin/ksh. Some scripts may need to change their shebang.

Comment 9 Michal Hlavinka 2011-04-12 08:22:06 UTC
*** Bug 695434 has been marked as a duplicate of this bug. ***

Comment 10 Michal Hlavinka 2012-11-06 13:13:42 UTC
*** Bug 871890 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.