Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619576 - missing deps in RHUI install
missing deps in RHUI install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Greguske
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 16:36 EDT by wes hayutin
Modified: 2011-04-25 13:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-25 13:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-07-29 16:36:50 EDT
RHEL5.5 x86_64 installed w/

%packages
@base
@core
fipscheck
device-mapper-multipath
sgpio



[root@dhcp231-93 test]# ./install_RHUA.sh 
Installing Red Hat Update Appliance packages

Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Local Package Process
Examining RHUI/rh-rhua-0.65-1.el5.noarch.rpm: rh-rhua-0.65-1.el5.noarch
Marking RHUI/rh-rhua-0.65-1.el5.noarch.rpm to be installed
Cannot open file: packages/grinder*. Skipping.
Cannot open file: packages/txt2rss*. Skipping.
Cannot open file: packages/createrepo*. Skipping.
Examining RHUI/python-hashlib-20081119-5.el5.x86_64.rpm: python-hashlib-20081119-5.el5.x86_64
Marking RHUI/python-hashlib-20081119-5.el5.x86_64.rpm to be installed
Cannot open file: packages/python-pycurl*. Skipping.
Examining RHUI/PyYAML-3.08-4.el5.x86_64.rpm: PyYAML-3.08-4.el5.x86_64
Marking RHUI/PyYAML-3.08-4.el5.x86_64.rpm to be installed
Cannot open file: packages/libyaml-0*. Skipping.
Resolving Dependencies
--> Running transaction check
---> Package PyYAML.x86_64 0:3.08-4.el5 set to be updated
--> Processing Dependency: libyaml-0.so.1()(64bit) for package: PyYAML
---> Package python-hashlib.x86_64 0:20081119-5.el5 set to be updated
---> Package rh-rhua.noarch 0:0.65-1.el5 set to be updated
--> Processing Dependency: httpd >= 2.2.3-40 for package: rh-rhua
--> Processing Dependency: grinder for package: rh-rhua
--> Finished Dependency Resolution
rh-rhua-0.65-1.el5.noarch from /rh-rhua-0.65-1.el5.noarch has depsolving problems
  --> Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
PyYAML-3.08-4.el5.x86_64 from /PyYAML-3.08-4.el5.x86_64 has depsolving problems
  --> Missing Dependency: libyaml-0.so.1()(64bit) is needed by package PyYAML-3.08-4.el5.x86_64 (/PyYAML-3.08-4.el5.x86_64)
rh-rhua-0.65-1.el5.noarch from /rh-rhua-0.65-1.el5.noarch has depsolving problems
  --> Missing Dependency: grinder is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
Error: Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
Error: Missing Dependency: libyaml-0.so.1()(64bit) is needed by package PyYAML-3.08-4.el5.x86_64 (/PyYAML-3.08-4.el5.x86_64)
Error: Missing Dependency: grinder is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Failed to install packages.  Your system needs to be installed with the @Base set of packages.
Comment 1 wes hayutin 2010-07-29 16:38:54 EDT
TAKE THE LAST COMMENT BACK...

HERE ARE THE MISSING DEPS



--> Finished Dependency Resolution
rh-rhua-0.65-1.el5.noarch from /rh-rhua-0.65-1.el5.noarch has depsolving problems
  --> Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
grinder-0.0.52-1.el5.noarch from /grinder-0.0.52-1.el5.noarch has depsolving problems
  --> Missing Dependency: python-pycurl is needed by package grinder-0.0.52-1.el5.noarch (/grinder-0.0.52-1.el5.noarch)
grinder-0.0.52-1.el5.noarch from /grinder-0.0.52-1.el5.noarch has depsolving problems
  --> Missing Dependency: createrepo is needed by package grinder-0.0.52-1.el5.noarch (/grinder-0.0.52-1.el5.noarch)
Error: Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
Error: Missing Dependency: python-pycurl is needed by package grinder-0.0.52-1.el5.noarch (/grinder-0.0.52-1.el5.noarch)
Error: Missing Dependency: createrepo is needed by package grinder-0.0.52-1.el5.noarch (/grinder-0.0.52-1.el5.noarch)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Failed to install packages.  Your system needs to be installed with the @Base set of packages.

[root@dhcp231-93 test]#
Comment 2 wes hayutin 2010-07-29 16:42:31 EDT
[root@dhcp231-93 test]# ./install_RHUA.sh 
Installing Red Hat Update Appliance packages

Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Local Package Process
Examining RHUI/rh-rhua-0.65-1.el5.noarch.rpm: rh-rhua-0.65-1.el5.noarch
Marking RHUI/rh-rhua-0.65-1.el5.noarch.rpm to be installed
Examining RHUI/grinder-0.0.52-1.el5.noarch.rpm: grinder-0.0.52-1.el5.noarch
Marking RHUI/grinder-0.0.52-1.el5.noarch.rpm to be installed
Examining RHUI/txt2rss-0.1-6.el5.noarch.rpm: txt2rss-0.1-6.el5.noarch
Marking RHUI/txt2rss-0.1-6.el5.noarch.rpm to be installed
Examining RHUI/createrepo-0.4.11-3.el5.noarch.rpm: createrepo-0.4.11-3.el5.noarch
Marking RHUI/createrepo-0.4.11-3.el5.noarch.rpm to be installed
Examining RHUI/python-hashlib-20081119-5.el5.x86_64.rpm: python-hashlib-20081119-5.el5.x86_64
Marking RHUI/python-hashlib-20081119-5.el5.x86_64.rpm to be installed
Examining RHUI/python-pycurl-7.15.5.1-4.el5.x86_64.rpm: python-pycurl-7.15.5.1-4.el5.x86_64
Marking RHUI/python-pycurl-7.15.5.1-4.el5.x86_64.rpm to be installed
Examining RHUI/PyYAML-3.08-4.el5.x86_64.rpm: PyYAML-3.08-4.el5.x86_64
Marking RHUI/PyYAML-3.08-4.el5.x86_64.rpm to be installed
Examining RHUI/libyaml-0.1.2-3.el5.x86_64.rpm: libyaml-0.1.2-3.el5.x86_64
Marking RHUI/libyaml-0.1.2-3.el5.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package PyYAML.x86_64 0:3.08-4.el5 set to be updated
---> Package createrepo.noarch 0:0.4.11-3.el5 set to be updated
---> Package grinder.noarch 0:0.0.52-1.el5 set to be updated
---> Package libyaml.x86_64 0:0.1.2-3.el5 set to be updated
---> Package python-hashlib.x86_64 0:20081119-5.el5 set to be updated
---> Package python-pycurl.x86_64 0:7.15.5.1-4.el5 set to be updated
---> Package rh-rhua.noarch 0:0.65-1.el5 set to be updated
--> Processing Dependency: httpd >= 2.2.3-40 for package: rh-rhua
---> Package txt2rss.noarch 0:0.1-6.el5 set to be updated
--> Finished Dependency Resolution
rh-rhua-0.65-1.el5.noarch from /rh-rhua-0.65-1.el5.noarch has depsolving problems
  --> Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
Error: Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-rhua-0.65-1.el5.noarch (/rh-rhua-0.65-1.el5.noarch)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Failed to install packages.  Your system needs to be installed with the @Base set of packages.
Comment 3 Jay Greguske 2010-07-30 10:06:07 EDT
Fixed in the 1.2 version of the rhel5-server-rhui-xml.in comps file used when Distilling the ISO.
Comment 4 wes hayutin 2010-08-03 15:50:24 EDT
verified
Comment 5 Jay Greguske 2011-04-25 13:25:54 EDT
Cleaning out old bugs. Feel free to reopen if you feel this one was closed in error.

Note You need to log in before you can comment on or make changes to this bug.