Bug 619582 - RHUI, install_cds.sh dep errors
RHUI, install_cds.sh dep errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Greguske
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 16:45 EDT by wes hayutin
Modified: 2011-04-25 13:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-25 13:26:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-07-29 16:45:36 EDT
[root@dhcp231-93 test]# ./install_CDS.sh 
Installing Red Hat Content Deliver Server packages

Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Local Package Process
Examining packages/rh-cds-0.16-1.el5.noarch.rpm: rh-cds-0.16-1.el5.noarch
Marking packages/rh-cds-0.16-1.el5.noarch.rpm to be installed
Examining packages/mod_python-3.3.1-12.el5.x86_64.rpm: mod_python-3.3.1-12.el5.x86_64
Marking packages/mod_python-3.3.1-12.el5.x86_64.rpm to be installed
Cannot open file: packages/httpd*. Skipping.
Resolving Dependencies
--> Running transaction check
---> Package mod_python.x86_64 0:3.3.1-12.el5 set to be updated
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_python
--> Processing Dependency: httpd >= 2.0.40 for package: mod_python
---> Package rh-cds.noarch 0:0.16-1.el5 set to be updated
--> Processing Dependency: httpd >= 2.2.3-40 for package: rh-cds
--> Finished Dependency Resolution
rh-cds-0.16-1.el5.noarch from /rh-cds-0.16-1.el5.noarch has depsolving problems
  --> Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-cds-0.16-1.el5.noarch (/rh-cds-0.16-1.el5.noarch)
mod_python-3.3.1-12.el5.x86_64 from /mod_python-3.3.1-12.el5.x86_64 has depsolving problems
  --> Missing Dependency: httpd >= 2.0.40 is needed by package mod_python-3.3.1-12.el5.x86_64 (/mod_python-3.3.1-12.el5.x86_64)
mod_python-3.3.1-12.el5.x86_64 from /mod_python-3.3.1-12.el5.x86_64 has depsolving problems
  --> Missing Dependency: httpd-mmn = 20051115 is needed by package mod_python-3.3.1-12.el5.x86_64 (/mod_python-3.3.1-12.el5.x86_64)
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_python-3.3.1-12.el5.x86_64 (/mod_python-3.3.1-12.el5.x86_64)
Error: Missing Dependency: httpd >= 2.2.3-40 is needed by package rh-cds-0.16-1.el5.noarch (/rh-cds-0.16-1.el5.noarch)
Error: Missing Dependency: httpd >= 2.0.40 is needed by package mod_python-3.3.1-12.el5.x86_64 (/mod_python-3.3.1-12.el5.x86_64)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Failed to install packages. The system needs to be installed with the @Base set of packages.

[root@dhcp231-93 test]#
Comment 1 Shveta 2010-07-30 02:49:28 EDT
[root@ip-10-161-89-207 rhuiso]# ./install_CDS.sh 
Installing Red Hat Content Deliver Server packages

Loaded plugins: fastestmirror, security
Setting up Local Package Process
Examining RHUI/rh-cds-0.16-1.el5.noarch.rpm: rh-cds-0.16-1.el5.noarch
Marking RHUI/rh-cds-0.16-1.el5.noarch.rpm to be installed
Loading mirror speeds from cached hostfile
Examining RHUI/mod_python-3.3.1-12.el5.x86_64.rpm: mod_python-3.3.1-12.el5.x86_64
Marking RHUI/mod_python-3.3.1-12.el5.x86_64.rpm as an update to mod_python-3.2.8-3.1.x86_64
Examining RHUI/httpd-2.2.3-43.el5.x86_64.rpm: httpd-2.2.3-43.el5.x86_64
RHUI/httpd-2.2.3-43.el5.x86_64.rpm: does not update installed package.
Resolving Dependencies
--> Running transaction check
---> Package mod_python.x86_64 0:3.3.1-12.el5 set to be updated
---> Package rh-cds.noarch 0:0.16-1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package      Arch     Version          Repository                         Size
================================================================================
Installing:
 rh-cds       noarch   0.16-1.el5       /rh-cds-0.16-1.el5.noarch          99 k
Updating:
 mod_python   x86_64   3.3.1-12.el5     /mod_python-3.3.1-12.el5.x86_64   2.7 M

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       1 Package(s)

Total size: 2.8 M
Is this ok [y/N]: y
Downloading Packages:


Package rh-cds-0.16-1.el5.noarch.rpm is not signed

Failed to install packages. The system needs to be installed with the @Base set of packages.
=======================================


Package mod_python-3.3.1-12.el5.x86_64.rpm is not signed


WorkAround :


[root@ip-10-161-89-207 rhuiso]# rpm -e mod_python
[root@ip-10-161-89-207 rhuiso]# rpm -ivh RHUI/mod_python-3.3.1-12.el5.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:mod_python             ########################################### [100%]
[root@ip-10-161-89-207 rhuiso]# rpm -ivh RHUI/rh-cds-0.16-1.el5.noarch.rpm 
Preparing...                ########################################### [100%]
   1:rh-cds                 ########################################### [100%]
Comment 2 Jay Greguske 2010-07-30 10:07:16 EDT
Fixed in the 1.2 version of the comps-rhel5-server-rhui.xml.in comps file used when Distilling the ISO.
Comment 3 Shveta 2010-08-02 06:14:34 EDT
Not fixed.
Comment 4 wes hayutin 2010-08-03 15:49:41 EDT
verified.. works in the latest iso 
I promise :)
Comment 5 Jay Greguske 2011-04-25 13:26:22 EDT
Cleaning out old bugs. Feel free to reopen if you feel this one was closed in error.

Note You need to log in before you can comment on or make changes to this bug.