Bug 619608 - request to include puppet and puppet-server packages in RHEL 6
request to include puppet and puppet-server packages in RHEL 6
Status: CLOSED DUPLICATE of bug 619630
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Ben Levenson
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 18:55 EDT by Jeffrey Blank
Modified: 2010-07-29 22:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 619630 (view as bug list)
Environment:
Last Closed: 2010-07-29 22:54:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Blank 2010-07-29 18:55:00 EDT
Description of problem:

The 'puppet' and 'puppet-server' packages are not currently included in the RHEL 6 beta.  This bugzilla entry is a request that these packages be added to RHEL 6 prior to release, or be included with RHEL 6.1 when it is released.  

Version-Release number of selected component (if applicable):

The packages 'puppet' and 'puppet-server' are currently at version 0.25.5-1.el6 in the EPEL repository:
http://download.fedora.redhat.com/pub/epel/beta/6/i386/puppet-0.25.5-1.el6.noarch.rpm

Version 2.6 is now available, and should also be available as an RPM package before long.


Additional info:

My organization operates a large number of systems which:
- are running RHEL 5, and will be upgraded to RHEL 6
- are air-gapped, i.e. are not connected to the Internet (though they are connected to Satellite Servers)
- are using Puppet for systems management


I am also personally involved in developing security baselines for DoD and NIST.  Including the puppet packages as part of the OS addresses the significant systems management problem.  It remains an outstanding issue that Windows (whatever else one may think about it) includes a management framework (group policy) while other OSes do not.  While RH Satellite Server allows for control of files on registered systems, this is nowhere near the level of granularity available in Puppet, nor does it easily allow for centralized control within a site.  Recent events also make it clear that Puppet has a certain level of momentum in the systems management space, so its inclusion into RHEL will not be granting it any undeserved legitimacy.
Comment 2 RHEL Product and Program Management 2010-07-29 19:27:31 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Jeffrey Blank 2010-07-29 21:12:52 EDT
I cloned this into 619630, and asked for inclusion in RHEL 6.1 instead.  Let me know if it's also a good idea to make noise with my support rep.  Thanks.


(In reply to comment #2)
> This issue has been proposed when we are only considering blocker
> issues in the current Red Hat Enterprise Linux release.
> 
> ** If you would still like this issue considered for the current
> release, ask your support representative to file as a blocker on
> your behalf. Otherwise ask that it be considered for the next
> Red Hat Enterprise Linux release. **
Comment 4 Bill Nottingham 2010-07-29 22:54:09 EDT
Might as well, yes. Closing this one... it's not happening at this stage for 6.0.

*** This bug has been marked as a duplicate of bug 619630 ***

Note You need to log in before you can comment on or make changes to this bug.