Bug 61962 - Dell 1600X Laptop Display Panel type has invalid vertical refresh rate
Dell 1600X Laptop Display Panel type has invalid vertical refresh rate
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: hwdata (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-26 05:26 EST by Barry K. Nathan
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 15:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2002-03-26 05:26:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The Dell 1600X laptop display type sets the vertical refresh rate (in the 
XF86Config-4 file) to 1Hz. Thus, X doesn't work unless I change this manually 
(to, for instance, "59-61" -- "59-60" also works, but "59", "60", and "61" all 
fail).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take Dell with 1600X1200 unprobeable display (like my Inspiron 5000e).
2. Proceed with skipjack installation, up to display configuration stuff.
3. Notice that the monitor is "unprobed" and manually choose Dell 1600X Laptop 
Display Panel (name might not be exactly that, but it's close).
4. Observe that vertical refresh rate gets set to 1Hz.
5. Test X configuration and see that it fails.
6. Choose text, not graphical, login (to make your life easier for the next 
steps).
7. Finish the install and reboot into skipjack.
8. Log in as root.
9. "startx" -- this fails.
10. vi /etc/X11/XF86Config-4, find the vertical refresh setting, change 
from "1" to "59-61" (or "59-60"), ZZ to save and exit. [you can use a 
different text editor if you wish, of course]
11. "startx" -- this time GNOME appears in 133dpi 1600x1200 glory. Yes, the 
fonts are tiny, but blowing those up on your own is probably not a big deal.

Actual Results:  described in steps above

Expected Results:  X test from anaconda should work, not fail; startx should 
work the first time, without futzing with XF86Config-4 file

Additional info:

see steps for bug reproduction above
Comment 1 Michael Fulbright 2002-03-26 12:04:08 EST
Thanks for the bug report I'll look into it.
Comment 2 Alexandre Oliva 2002-04-07 03:07:21 EDT
I get the same results on my Inspiron 8000.  I asked Dell about this, a while
ago, and the respose I got was that the primary display was the external one. 
If it was not connected, DAC probing was actually expected return such an odd
value as 1.  At least, this was oen of the hand-waving explanations I got when I
complained that things didn't work very well with the nvidia geforce2go video
card I got.

I've been using mostly the VESA driver ever since (that doesn't use the retrace
times at all), so things work fine despite the `1'.  I considered using the
proprietary driver from nvidia, but it won't let the laptop suspend :-(

I hope you haven't got an nvidia card.
Comment 3 Michael Fulbright 2002-04-11 19:50:53 EDT
I guess we need to change the hwdata values for this monitor to be a little more
tolerant.
Comment 4 Bill Nottingham 2002-04-11 21:07:23 EDT
This already has 59-80 for the refresh rate... I'm not sure what else to put there.
Comment 5 Barry K. Nathan 2002-04-13 03:07:29 EDT
I'm still seeing this with skipjack-beta2. The refresh rate might be specified
as 59-80 for all I know, but the *installer* is going ahead and showing "1", and
I have to manually specify 59-61 (I assume a larger range would work too). It
sounds to me like the installer may be ignoring the data for some reason. :( (I
haven't looked at the source or anything like that yet, however.)
Comment 6 Michael Fulbright 2002-04-15 15:36:56 EDT
This is a bug in the hwdata.

Fixed in hwdata-0.13-1.
Comment 7 Jay Turner 2002-04-18 20:29:39 EDT
Fix confirmed in 0.14-1

Note You need to log in before you can comment on or make changes to this bug.