Bug 619655 - Screen corruption with radeon driver (Radeon X1400), dual monitor and nomodeset
Screen corruption with radeon driver (Radeon X1400), dual monitor and nomodeset
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jérôme Glisse
Desktop QE
: RHELNAK, Triaged
Depends On:
Blocks: 713024
  Show dependency treegraph
 
Reported: 2010-07-30 00:38 EDT by Mike Khusid
Modified: 2013-04-02 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-13 15:45:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log and /var/log/messages (25.97 KB, application/x-bzip2)
2010-07-30 00:44 EDT, Mike Khusid
no flags Details
Screenshot1 (1.47 MB, image/jpeg)
2010-07-30 00:45 EDT, Mike Khusid
no flags Details
Screenshot2 (1.50 MB, image/jpeg)
2010-07-30 00:46 EDT, Mike Khusid
no flags Details
Screenshot3 (1.40 MB, image/jpeg)
2010-07-30 00:47 EDT, Mike Khusid
no flags Details
messages from the archive in comment 1 (70.40 KB, text/plain)
2010-08-20 16:08 EDT, Matěj Cepl
no flags Details
Xorg.0.log from the archive in comment 1 (124.01 KB, text/plain)
2010-08-20 16:08 EDT, Matěj Cepl
no flags Details
lspci from the archive in comment 1 (1.92 KB, text/plain)
2010-08-20 16:08 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Mike Khusid 2010-07-30 00:38:13 EDT
Description of problem:
Running ATI/Nvidia smoke tests on ATI hardware.  
Driver: radeon Video card: ATI Mobility 
Kernel: 2.6.32-44.1.el6.x86_64
Kernel boot option: nomodeset

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-6.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Connect VGA output, enable attached LCD panel
2. Boot with kernel option nomodeset
3. Start Firefox, Terminal and Nautilus
  
Actual results:
Screen corruption, see images attached

Expected results:
No screen corruption

Additional info:
No corruption observed with kernel modesetting.
Comment 1 Mike Khusid 2010-07-30 00:44:10 EDT
Created attachment 435456 [details]
Xorg log and /var/log/messages
Comment 2 Mike Khusid 2010-07-30 00:45:10 EDT
Created attachment 435457 [details]
Screenshot1
Comment 3 Mike Khusid 2010-07-30 00:46:31 EDT
Created attachment 435458 [details]
Screenshot2
Comment 4 Mike Khusid 2010-07-30 00:47:50 EDT
Created attachment 435459 [details]
Screenshot3

Apologies for multiple attachments, bugzilla wouldn't let me attach one archive with all three of them.
Comment 6 RHEL Product and Program Management 2010-07-30 01:07:39 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 Bill Nottingham 2010-07-30 12:21:37 EDT
Note that 'nomodeset' bugs are not going to be considered blockers, since the default is modesetting.
Comment 8 Kevin E. Martin 2010-08-09 16:35:45 EDT
(In reply to comment #7)
> Note that 'nomodeset' bugs are not going to be considered blockers, since the
> default is modesetting.    

Moving to 6.1
Comment 9 Matěj Cepl 2010-08-20 16:08:46 EDT
Created an attachment (id=440032)
messages from the archive in comment 1
Comment 10 Matěj Cepl 2010-08-20 16:08:51 EDT
Created an attachment (id=440033)
Xorg.0.log from the archive in comment 1
Comment 11 Matěj Cepl 2010-08-20 16:08:56 EDT
Created an attachment (id=440034)
lspci from the archive in comment 1
Comment 12 RHEL Product and Program Management 2011-01-06 23:29:26 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 Suzanne Yeghiayan 2011-01-07 11:09:28 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 14 RHEL Product and Program Management 2011-02-01 00:58:58 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 15 RHEL Product and Program Management 2011-02-01 13:31:31 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 19 datahal42 2011-04-07 07:21:40 EDT
hi

I had a similar problem for the snapshots that I've seen.

I solved the problem.

the problem is in the mix of drivers 64 and 32 bit in ati. (with ati proprietary drivers)

####the solution is very simple####

delete the 32 bit ati driver. no the 32 bit library. "the module 32 bit" 

my problem was that 32 and 64 bit modules were installed in my system 64 bit

in fedora 14 and rhl6 

is just that.
Comment 20 Jérôme Glisse 2011-05-20 09:41:40 EDT
Mike does it works if you boot without nomodeset. We don't support when nomodeset option is given as a parameter.
Comment 23 datahal42 2011-06-12 06:13:52 EDT
similar problem with gnome3 + ati-open-source-driver some flickering
Comment 25 RHEL Product and Program Management 2011-06-13 15:45:49 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.