Bug 61970 - ImportError: No module named utils
Summary: ImportError: No module named utils
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: printconf   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-26 13:55 UTC by Mario Mikocevic
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-26 15:03:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mario Mikocevic 2002-03-26 13:55:59 UTC
AAArgh ! Not again !

Description of Problem:
# printconf-gui                                                         
Traceback (most recent call last):
  File "/usr/sbin/printconf-gui", line 7, in ?
    import printconf_gui
  File "/usr/share/printconf/util/printconf_gui.py", line 41, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 82, in ?
    from xml.utils import qp_xml
ImportError: No module named utils
# printconf-tui 
Traceback (most recent call last):
  File "/usr/sbin/printconf-tui", line 7, in ?
    import printconf_tui
  File "/usr/share/printconf/util/printconf_tui.py", line 44, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 82, in ?
    from xml.utils import qp_xml
ImportError: No module named utils


Version-Release number of selected component (if applicable):
# rpm -qa | grep printconf
printconf-0.3.74-1
printconf-gui-0.3.74-1
# rpm -qa | grep Py
PyXML-0.7-4
# rpm -qa | grep python       
python-2.2-7
python-devel-2.2-7
rpm-python-4.0.4-7x.7


Additional Information:
Will somebody recompile/whatever PyXML package so that works with python 2.2 !

Comment 1 Bill Nottingham 2002-03-28 22:39:30 UTC
To have the printconf stack work with python version 2, you *will* need to
rebuild the various python modules, all the way to pygtk. This will be fixed for
a future release that ships with python2 as the default.


Note You need to log in before you can comment on or make changes to this bug.