Bug 619719 - [comps] [ALL_LANG] Translation updates
[comps] [ALL_LANG] Translation updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ankit Patel
Release Test Team
: RHELNAK, Translation
: 567463 (view as bug list)
Depends On: 567463 605556
Blocks: 575750
  Show dependency treegraph
 
Reported: 2010-07-30 05:46 EDT by Ankit Patel
Modified: 2011-05-19 08:55 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:55:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
or_IN Screenshot (52.92 KB, image/png)
2010-08-20 14:22 EDT, A S Alam
no flags Details
zh_CN untranslated (31.87 KB, image/png)
2010-08-20 14:23 EDT, A S Alam
no flags Details
ml_IN Issue 1 (76.85 KB, image/png)
2010-08-20 14:24 EDT, A S Alam
no flags Details
ml_IN Issue 2 (65.88 KB, image/png)
2010-08-20 14:24 EDT, A S Alam
no flags Details
ml_IN Issue 3 (63.71 KB, image/png)
2010-08-20 14:24 EDT, A S Alam
no flags Details
bn_IN Untranslated String (50.34 KB, image/png)
2010-08-20 14:25 EDT, A S Alam
no flags Details
it_IT translation of Languages (94.74 KB, image/png)
2011-03-06 19:24 EST, Kenichi Takemura
no flags Details
A tarball of translations for remaining languages (52.42 KB, application/x-bzip2)
2011-04-27 05:38 EDT, Ankit Patel
no flags Details

  None (edit)
Description Ankit Patel 2010-07-30 05:46:00 EDT
Red Hat officially supports 22 languages, where translations is a major part. So, translations quality and completeness is required for all Tier1 components of RHEL6. comps is one of the localization Tier1 component that has to be localized in Red Hat supported Languages. This bug is to provide translation updates in terms of patches or tarball for comps for Red Hat supported languages.

Additional Information:-
* Since the POT file updated few days before this bug has to be raised: "POT-Creation-Date: 2010-05-25 11:30-0400\n" from POT header.

* Translations will be submitted here: https://translate.fedoraproject.org/projects/p/rhel-comps/c/master/

* I will provide an update when translations are completed and submitted to transifex for Red Hat supported languages.
Comment 2 RHEL Product and Program Management 2010-07-30 06:08:03 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Ankit Patel 2010-08-10 05:01:45 EDT
All Red Hat Supported languages (except Assamese [as.po], due to no resource) are completed for translations and available upstream: https://translate.fedoraproject.org/projects/p/rhel-comps/c/master/

Could you please make a new build grabbing the latest translations from git repo?

Thanks!
Ankit
Comment 4 Dennis Gregorovic 2010-08-10 07:25:14 EDT
I've pulled the latest translations and they should appear in the next compose.
Comment 5 Bill Nottingham 2010-08-10 11:45:07 EDT
*** Bug 567463 has been marked as a duplicate of this bug. ***
Comment 6 Dennis Gregorovic 2010-08-12 10:03:26 EDT
All fixes should be in the RHEL6.0-20100811.2 tree.
Comment 7 Alexander Todorov 2010-08-20 07:12:30 EDT
Hi Ankit,
can you verify that all translations are in place for comps with the latest snapshot? Thanks!
Comment 8 A S Alam 2010-08-20 14:22:09 EDT
Fail Test Cases for Few languages:

zh_CN - language Name (Swati) untranslated
or_IN - Dotted Circle (Translation Needs review)
ml_IN - Translation needs review (Screenshot atach)
bn_IN - Need to confirm whether it is intentional (Screenshot atach)
as_IN - N/A - Comment #3

Test Result with Detail:
https://tcms.engineering.redhat.com/runs/?a=search&search=Comps%20-%20Translation%20Testing

Snapshot #12
Comment 9 A S Alam 2010-08-20 14:22:38 EDT
Created attachment 440008 [details]
or_IN Screenshot
Comment 10 A S Alam 2010-08-20 14:23:11 EDT
Created attachment 440009 [details]
zh_CN untranslated
Comment 11 A S Alam 2010-08-20 14:24:04 EDT
Created attachment 440010 [details]
ml_IN Issue 1
Comment 12 A S Alam 2010-08-20 14:24:28 EDT
Created attachment 440011 [details]
ml_IN Issue 2
Comment 13 A S Alam 2010-08-20 14:24:52 EDT
Created attachment 440012 [details]
ml_IN Issue 3
Comment 14 A S Alam 2010-08-20 14:25:42 EDT
Created attachment 440013 [details]
bn_IN Untranslated String
Comment 15 Alexander Todorov 2010-08-21 07:07:13 EDT
Moving back to ASSIGNED based on previous comments - missing translations.
Comment 16 Manoj Kumar Giri 2010-08-25 03:46:33 EDT
Corrected the dotted circle issue for Oriya (or_IN) in https://translate.fedoraproject.org/projects/p/rhel-comps/c/master/ as well as in downstream (revision 2070).
Comment 20 Ani Peter 2010-08-26 01:27:24 EDT
Corrected and completed the translations fro Malayalam (ml_IN):
https://translate.fedoraproject.org/projects/p/rhel-comps/c/master/

Thanks!!
Comment 21 Wei Liu 2010-08-29 06:01:05 EDT
Updated the translation for zh-CN at:
https://translate.fedoraproject.org/projects/p/rhel-comps/c/master/

Thanks!
Comment 24 Runa Bhattacharjee 2010-08-31 08:37:27 EDT
As far as I can understand, 'Server Platform' refers to the supported libraries for the 'Red Hat Enterprise Linux Server Platform' variant and hence this was not translated intentionally for bn-IN. Please correct me if this is not right.
Comment 25 Ankit Patel 2010-09-01 07:52:45 EDT
Reassigning this bug back to comps maintainers, as localization teams' translation task is completed here.

Thanks!
Ankit
Comment 28 Dennis Gregorovic 2011-02-04 13:53:23 EST
re-assigning back to translation.  I've updated http://git.fedorahosted.org/git/?p=rhel-comps.git;a=blob;f=po/comps.pot with the latest comps.xml source strings.
Comment 29 Ankit Patel 2011-02-07 03:15:01 EST
What's the last date to submit translations in order to get it included in RHEL6.1?
Comment 31 Kenichi Takemura 2011-03-06 19:24:50 EST
Created attachment 482567 [details]
it_IT translation of Languages

Hi I would like to add the following issue into this bug.

[it_IT] the translation of Languages is not correct, it should say Lingue (not Linguaggi)
Comment 32 Denise Dumas 2011-04-14 10:50:48 EDT
Ankit, what is the status here? Please dont wait til the last possible date to get this in!
Comment 33 Ankit Patel 2011-04-15 01:58:42 EDT
(In reply to comment #32)
> Ankit, what is the status here? Please dont wait til the last possible date to
> get this in!

Denise,

Please confirm, http://www.transifex.net/projects/p/comps/resource/default/ is the right location to submit translations?

Thanks!
Ankit
Comment 34 Bill Nottingham 2011-04-15 10:41:49 EDT
No, that's the Fedora comps file.
Comment 35 Ankit Patel 2011-04-18 00:51:58 EDT
Please provide me the location to submit translations of comps, if that doesn't exist then having the git repo location to checkout RHEL comps translation would be sufficient. I would checkout those and get it repo'ed into internal local repo and get it translated.

Thanks!
Ankit
Comment 36 Dennis Gregorovic 2011-04-18 12:50:03 EDT
Hi Ankit,

The RHEL comps translations are now at

https://www.transifex.net/projects/p/rhel-comps/resource/default/

Cheers
-- Dennis
Comment 40 Francesco Valente 2011-04-20 19:13:49 EDT
Ankit there is a problem mate, I can't download this module therefore I can't translate it.

Wwhy this is not available for translation to normal ferdora members (including myself). Unable to translate it for now because I need the maintainer of this module to allow me to create a new italian group

Cheers

Francesco
Comment 41 Noriko Mizumoto 2011-04-20 20:03:33 EDT
Thanks Francesco for picking this up.

Again, this module is set the access control option to which 'not use Fedora translation team (aka FLP) and create own translation team'. Therefore none of redhat translators or fedora translators can work on this module, unless creating new team for every language. 
Now all redhat translators started requesting new team on tx.net for this update, but we need to wait for the approval of Transifex team of Infidex. It is difficult for translators to maintain their language team by every package.

It will be great help if the setting to be changed at the maintainer's side.
FYI, this setting can be changed if you who have right permisiion go 'Access Control' tab, choose 'Outsourced access' (currently set as Limited access), and choose 'Fedora project' from dropdown menu.
Comment 43 Dennis Gregorovic 2011-04-21 09:28:14 EDT
(In reply to comment #41)

> It will be great help if the setting to be changed at the maintainer's side.
> FYI, this setting can be changed if you who have right permisiion go 'Access
> Control' tab, choose 'Outsourced access' (currently set as Limited access), and
> choose 'Fedora project' from dropdown menu.

Thanks for the tip.  I was unaware of this option.  I've gone ahead and updated the access settings.
Comment 44 Ankit Patel 2011-04-27 05:38:14 EDT
Created attachment 495158 [details]
A tarball of translations for remaining languages

Hi Denise,

I have attached a tarball of translations for the languages: de, fr, it, ko, pt_BR, zh_TW and remaining languages are available from transifex itself: https://www.transifex.net/projects/p/rhel-comps/resource/default/

Please do get back to me in case you need any further details.

Thank You!
Ankit
Comment 46 Dennis Gregorovic 2011-04-27 14:35:06 EDT
Thanks for the translations.  I've pulled them in and rebuilt comps-rhel6.xml
Comment 49 errata-xmlrpc 2011-05-19 08:55:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0540.html

Note You need to log in before you can comment on or make changes to this bug.