Bug 619744 - [kexec-tools] POT file outdated
[kexec-tools] POT file outdated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cong Wang
Ankit Patel
: i18n, RHELNAK, Translation
Depends On:
Blocks: 576455 589214
  Show dependency treegraph
 
Reported: 2010-07-30 08:10 EDT by Ankit Patel
Modified: 2013-09-29 22:19 EDT (History)
7 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-135_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:46:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kexec "Enable Kdump?" message appears in English in Firstboot (130.51 KB, image/png)
2010-08-04 08:28 EDT, Ankit Patel
no flags Details
kexec "insufficient memory" message appears in English in Firstboot (158.08 KB, image/png)
2010-08-04 08:29 EDT, Ankit Patel
no flags Details
kexec-tools po files (35.57 KB, application/x-gzip)
2010-08-06 04:02 EDT, Cong Wang
no flags Details
updated tarball (35.82 KB, application/x-gzip)
2010-08-09 03:17 EDT, Cong Wang
no flags Details
Translation patch for kexec-tools for Red Hat supported languages (151.76 KB, patch)
2010-08-10 03:53 EDT, Ankit Patel
no flags Details | Diff
Translation tarball for kexec-tools for Red Hat supported languages (32.61 KB, application/x-gzip)
2010-08-10 04:59 EDT, Ankit Patel
no flags Details

  None (edit)
Description Ankit Patel 2010-07-30 08:10:03 EDT
Description of problem:
Kexec-tools pot file is outdated because of which localized screen shows couple of messages in English.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-132.el6.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. "LANG=gu_IN.UTF-8 firstboot"
2. go through the last screen (that's kdump) in the firstboot
3. Check the messages like "Enable kdump?" and "Insufficient memory to configure kdump!".
  
Actual results:
"Enable kdump?" and "Insufficient memory to configure kdump!" appears in English.

Expected results:
"Enable kdump?" and "Insufficient memory to configure kdump!" should appears localized.

Additional info:
POT file needs to be regenerated.
POT File doesn't contain the mentioned messages: https://translate.fedoraproject.org/projects/p/kexec-tools/c/HEAD/view/po/kexec-tools.pot
Comment 2 RHEL Product and Program Management 2010-07-30 08:28:09 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Ankit Patel 2010-08-04 08:28:47 EDT
Created attachment 436515 [details]
kexec "Enable Kdump?" message appears in English in Firstboot
Comment 4 Ankit Patel 2010-08-04 08:29:24 EDT
Created attachment 436516 [details]
kexec "insufficient memory" message appears in English in Firstboot
Comment 5 Cong Wang 2010-08-06 04:02:29 EDT
Created attachment 437061 [details]
kexec-tools po files

kexec-tools-po.tar.gz
Comment 6 Ankit Patel 2010-08-06 07:08:10 EDT
Well,(In reply to comment #5)
> Created an attachment (id=437061) [details]
> kexec-tools po files
> 
> kexec-tools-po.tar.gz    

Amerigo Wang,

Thank you for the po files attachment, but I need POT file where the messages "insufficient memory" and "Enable Kdump?" are included.

I guess there is an i18n issue here with this package, which is not allowing us to update the POT file or PO files.

Check the attachments I have made.

Thanks!
Ankit
Comment 7 Ankit Patel 2010-08-06 07:09:07 EDT
Can somebody from i18n team try to explain the issue of gettextization and POT updation here?

Thanks!
Ankit
Comment 8 Cong Wang 2010-08-09 02:44:23 EDT
(In reply to comment #6)
> 
> Thank you for the po files attachment, but I need POT file where the messages
> "insufficient memory" and "Enable Kdump?" are included.
> 

I am confused now.

"Enable Kdump?" is included already, I checked zh_CN.po. The reason why it is not displayed correctly is that there is a bug in firstboot_kdump.py, I fix it now. So you don't need to worry this one any more.

"insufficient memory" is not, it is newly added, and is supposed to be translated by your team, isn't it?
Comment 9 Ankit Patel 2010-08-09 02:52:43 EDT
(In reply to comment #8)
> (In reply to comment #6)
> > 
> > Thank you for the po files attachment, but I need POT file where the messages
> > "insufficient memory" and "Enable Kdump?" are included.
> > 
> 
> I am confused now.
> 
> "Enable Kdump?" is included already, I checked zh_CN.po. The reason why it is
> not displayed correctly is that there is a bug in firstboot_kdump.py, I fix it
> now. So you don't need to worry this one any more.

Well, in POT file you will find "_Enable Kdump?" not "Enable kdump?", that's the reason it's not matching and throwing localized GUI.

> 
> "insufficient memory" is not, it is newly added, and is supposed to be
> translated by your team, isn't it?    

it can be only translated into PO files unless it's included in kexec-tools.pot file by the package maintainer.

Thanks!
Ankit
Comment 10 Cong Wang 2010-08-09 03:17:39 EDT
Created attachment 437531 [details]
updated tarball

Ankit, I re-generate the POT file, please check if this one is OK.
Comment 11 Ankit Patel 2010-08-09 03:37:20 EDT
(In reply to comment #10)
> Created an attachment (id=437531) [details]
> updated tarball
> 
> Ankit, I re-generate the POT file, please check if this one is OK.    

I see the message "Insufficient memory to configure kdump!" added but I don't see a message "Enable Kdump?" as seen in comment #3 attachment, rather I see "_Enable kdump?".

Anyways, if that's the change made at the source code level too, it's fine to go ahead, and I will get back to you with translation updates by tomorrow.

Thanks!
Ankit
Comment 12 Cong Wang 2010-08-09 04:10:18 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > Created an attachment (id=437531) [details] [details]
> > updated tarball
> > 
> > Ankit, I re-generate the POT file, please check if this one is OK.    
> 
> I see the message "Insufficient memory to configure kdump!" added but I don't
> see a message "Enable Kdump?" as seen in comment #3 attachment, rather I see
> "_Enable kdump?".
> 

Yes, it should be "_Enable kdump?", see those po files.

> Anyways, if that's the change made at the source code level too, it's fine to
> go ahead, and I will get back to you with translation updates by tomorrow.
> 

Thanks much!
Comment 13 Ankit Patel 2010-08-10 03:53:58 EDT
Created attachment 437803 [details]
Translation patch for kexec-tools for Red Hat supported languages

Applying this patch should update translations for all Red Hat Supported languages (except Assamese [as.po], due to no resource).

Thanks!
Ankit
Comment 14 Cong Wang 2010-08-10 04:53:27 EDT
Hi, Ankit, could you please upload the updated tarball? Based on the one that I sent to you. This would be better for me to update it. Thanks.
Comment 15 Ankit Patel 2010-08-10 04:59:53 EDT
Created attachment 437815 [details]
Translation tarball for kexec-tools for Red Hat supported languages

Okay,

Check this tarball in that case.

Thanks!
Ankit
Comment 16 Ankit Patel 2010-08-10 05:57:50 EDT
FIXED.

TESTED and VERIFIED with kexec-tools-2.0.0-135.el6.

Thanks!
Ankit
Comment 17 releng-rhel@redhat.com 2010-11-11 09:46:22 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.