Bug 61977 - snmpd crashes when disk / 10000 is enabled
snmpd crashes when disk / 10000 is enabled
Status: CLOSED DUPLICATE of bug 55840
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 10:18 EST by Lauri Jesmin
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 10:18:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Jesmin 2002-03-26 10:18:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020212

Description of problem:
snmpd from ucd-snmp crashes, when i uncomment row
disk / 10000
and start it

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.uncomment disk / 10000 row in /etc/snmp/snmpd.conf
2.start snmpd
	

Actual Results:  crash

Expected Results:  would like to see it working

Additional info:

Name        : ucd-snmp
Version     : 4.2.3
Release     : 1.7.2.3

Watching with strace, it crashes after loading MIB files. 
Something like that: 
read(5, "SNMPv2-TM DEFINITIONS ::= BEGIN\n"..., 4096) = 3981
read(5, "", 4096)                       = 0
close(5)                                = 0
munmap(0x40001000, 4096)                = 0
open("/etc/snmp/snmpd.conf", O_RDONLY)  = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=14824, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40001000
read(5, "################################"..., 4096) = 4096
read(5, "   system.sysServices.0 = 72\n\n\n#"..., 4096) = 4096
read(5, "= \"/bin/sh /tmp/shtest\"\n# enterp"..., 4096) = 4096
open("unknown", O_RDONLY)               = -1 ENOENT (No such file or directory)
brk(0x80c0000)                          = 0x80c0000
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
Comment 1 Phil Knirsch 2002-03-26 10:22:39 EST

*** This bug has been marked as a duplicate of 55840 ***

Note You need to log in before you can comment on or make changes to this bug.