Bug 619775 - [abrt] crash in NetworkManager-gnome-1:0.8.1-1.fc13: nag_dialog_response_cb: Process /usr/bin/nm-applet was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in NetworkManager-gnome-1:0.8.1-1.fc13: nag_dialog_response_cb: ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:daa59df1eea43148ab3498f28d1...
Keywords:
: 625619 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-30 14:04 UTC by Terry Polzin
Modified: 2010-09-26 04:34 UTC (History)
3 users (show)

Fixed In Version: NetworkManager-0.8.1-4.git20100817.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 22:05:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.89 KB, text/plain)
2010-07-30 14:04 UTC, Terry Polzin
no flags Details

Description Terry Polzin 2010-07-30 14:04:57 UTC
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: nm-applet --sm-disable
comment: Cannont connect to WPA2 secured lan (worked in f12)
component: NetworkManager
crash_function: nag_dialog_response_cb
executable: /usr/bin/nm-applet
global_uuid: daa59df1eea43148ab3498f28d1ec83f0846aade
kernel: 2.6.33.6-147.fc13.i686.PAE
package: NetworkManager-gnome-1:0.8.1-1.fc13
rating: 4
reason: Process /usr/bin/nm-applet was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 Terry Polzin 2010-07-30 14:04:59 UTC
Created attachment 435565 [details]
File: backtrace

Comment 2 Jirka Klimes 2010-08-03 15:40:18 UTC
Reproducer ro the backtrace in #comment 1:
1. Click on a WPA network with EAP
2. don't choose any certificate, type password
3. click 'Connect'
4. click 'Choose CA Certificate' on the warning dialog
5. click 'Connect' once more
6. the crash appears

Comment 3 Jirka Klimes 2010-08-03 15:44:12 UTC
Sorry, step 6 is missing in the previous comment:

1. Click on a WPA network with EAP
2. don't choose any certificate, type password
3. click 'Connect'
4. click 'Choose CA Certificate' on the warning dialog
5. click 'Connect' once more
6. click 'Ignore'
7. the crash appears

Comment 4 Jirka Klimes 2010-08-03 15:46:31 UTC
Reproducer for the same issue, but different symptoms:

1. Click on a WPA network with EAP
2. don't choose any certificate, type password
3. click 'Connect'
4. click 'Choose CA Certificate' on the warning dialog
5. click 'Connect' once more
6. click 'Choose CA Certificate' on the warning dialog
7. crash appears:
*** glibc detected *** nm-applet: malloc(): smallbin double linked list corrupted: 0x000000000271d7e0 ***

Comment 5 Jirka Klimes 2010-08-03 15:48:33 UTC
The bug is fixed upstream in nm-applet:

8eff360933e903abd0e35e48aa83c431ed0dd6a6 (master)
ecc6d7467c1c914876c0fd815039f650156e0345 (NMA_0_8)

Comment 6 Fedora Update System 2010-08-17 17:10:22 UTC
NetworkManager-0.8.1-4.git20100817.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc12

Comment 7 Fedora Update System 2010-08-17 17:12:10 UTC
NetworkManager-0.8.1-4.git20100817.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc13

Comment 8 Fedora Update System 2010-08-17 17:14:03 UTC
NetworkManager-0.8.1-4.git20100817.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc14

Comment 9 Fedora Update System 2010-08-19 20:32:34 UTC
NetworkManager-0.8.1-5.git20100818.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-5.git20100818.fc14

Comment 10 Fedora Update System 2010-08-20 02:13:38 UTC
NetworkManager-0.8.1-4.git20100817.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc13

Comment 11 Jirka Klimes 2010-08-23 14:41:18 UTC
*** Bug 625619 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2010-08-23 22:05:04 UTC
NetworkManager-0.8.1-4.git20100817.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-08-24 01:20:10 UTC
NetworkManager-0.8.1-5.git20100818.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-09-01 01:25:52 UTC
NetworkManager-0.8.1-6.git20100831.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc13

Comment 15 Fedora Update System 2010-09-01 01:42:54 UTC
NetworkManager-0.8.1-6.git20100831.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc12

Comment 16 Fedora Update System 2010-09-26 04:34:30 UTC
NetworkManager-0.8.1-6.git20100831.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.