Bug 619838 - RegistrationService Errors During User Creation Cause Creation to Silently Fail
RegistrationService Errors During User Creation Cause Creation to Silently Fail
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
0.3.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Provaznik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 12:34 EDT by Ben Browning
Modified: 2011-12-08 09:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-14 11:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Browning 2010-07-30 12:34:36 EDT
Description of problem:
If an error occurs when saving the RegistrationService record for a new user, the user gets displayed the new user form again with no indication of what went wrong.

Steps to Reproduce:
1. Remove all roles from your development database (to simulate incorrect seed data).
2. Try to register for a new user account.
  
Actual results:
The new user form is displayed with no indication of what went wrong. There is no indication in the development log of what happened.

Expected results:
There should be some indication that something went wrong in the UI and ideally a stacktrace of the error in the development log.
Comment 1 wes hayutin 2011-06-14 11:54:22 EDT
closing out old bugs that dev has not addressed :(
Comment 2 wes hayutin 2011-12-08 09:08:47 EST
perm close

Note You need to log in before you can comment on or make changes to this bug.