Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619844 - Wallaby utils should fail with a descriptive message when they can't connect to the store
Wallaby utils should fail with a descriptive message when they can't connect ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: wallaby-utils (Show other bugs)
Development
All Linux
low Severity medium
: 1.3
: ---
Assigned To: Will Benton
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 13:05 EDT by Will Benton
Modified: 2010-10-20 07:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Benton 2010-07-30 13:05:32 EDT
Description of problem:

The error message that the wallaby utilities display when they fail to connect to the wallaby agent is generally unhelpful.

Version-Release number of selected component (if applicable):

0.6.3-1

Actual results:

QMF method calls will fail because the variable that should have a store object is nil, giving an "undefined method for nil:NilClass" error.

Expected results:

It would be more helpful for the tools to fail with a meaningful error message in this case.
Comment 1 Will Benton 2010-08-03 02:59:33 EDT
This is fixed in 0.9.0.
Comment 2 Lubos Trilety 2010-10-15 08:35:18 EDT
# service wallaby stop
# wallaby inventory
Console Connection Established...
fatal:  cannot find a wallaby agent on the specified broker (localhost:5672); is one running?
use -h for help

Tested with (version):
condor-wallaby-client-3.6-6.el5
wallaby-utils-0.9.18-2.el5
ruby-wallaby-0.9.18-2.el5
condor-wallaby-base-db-1.4-5.el5
python-wallabyclient-3.6-6.el5
condor-wallaby-tools-3.6-6.el5
wallaby-0.9.18-2.el5

Tested on:
RHEL5 i386,x86_64  - passed

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.