Bug 619910 - iptables hangs when shutting down system
Summary: iptables hangs when shutting down system
Status: CLOSED DUPLICATE of bug 617505
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iptables   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: iptables-maint-list
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords: RHELNAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-30 20:36 UTC by Eric Blake
Modified: 2010-07-30 21:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 21:49:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Blake 2010-07-30 20:36:31 UTC
Description of problem:
Every time I go to shut down my RHEL-6 system, iptables hangs.


Version-Release number of selected component (if applicable):
kernel-2.6.32-54.el6.x86_64
iptables-1.4.7-3.el6.x86_64
libvirt-0.8.1-20.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. 'sudo reboot', and watch log go by
2.
3.
  
Actual results:
Log hangs with:
ip6tables: Flushing firewall rules:                        [  OK  ]
ip6tables: Setting chains to policy ACCEPT: filter         [  OK  ]
ip6tables: Unloading modules:                              [  OK  ]
iptables: Flushing firewall rules:                         [  OK  ]
iptables: Setting chains to policy ACCEPT: mangle nat filte[  OK  ]
iptables: Unloading modules: 

Expected results:
reboot should succeed

Additional info:
Don't know if libvirt has anything to do with it, but I do know that having libvirtd running causes some iptables manipulations.

Comment 2 RHEL Product and Program Management 2010-07-30 21:07:38 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Bill Nottingham 2010-07-30 21:49:49 UTC

*** This bug has been marked as a duplicate of bug 617505 ***


Note You need to log in before you can comment on or make changes to this bug.