Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619946 - Bad path in %install for winbind
Bad path in %install for winbind
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba4 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 19:20 EDT by Kenneth Porter
Modified: 2010-08-03 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 12:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix macro expansion when all server packages are enabled (1.53 KB, application/octet-stream)
2010-07-30 19:20 EDT, Kenneth Porter
no flags Details

  None (edit)
Description Kenneth Porter 2010-07-30 19:20:14 EDT
Created attachment 435698 [details]
Patch to fix macro expansion when all server packages are enabled

I'm building the server packages on an up-to-date Fedora 12 (no samba 3 installed) and the %install clause for winbind breaks with an empty path. I'm attaching a patch. Adding a slash between the variables seems to fix it. It looks like rpmbuild's macro expansion is treating "$RPM_BUILD_ROOT%{_lib}" as a single macro instead of two concatenated macros. But neither has a slash, so the slash is needed anyway.
Comment 1 Kenneth Porter 2010-07-30 19:22:11 EDT
The source package is samba4-4.0.0-24.alpha11.fc14.src.rpm.
Comment 2 Matthew Barnes 2010-08-03 12:37:08 EDT
Path fixed in samba4-4.0.0-25.alpha11.fc14.

Note You need to log in before you can comment on or make changes to this bug.