Bug 619981 - Strange compiz ati problem - screen upside down and strings wrong way around
Summary: Strange compiz ati problem - screen upside down and strings wrong way around
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-31 05:59 UTC by Daniel Rowe
Modified: 2010-07-31 15:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-31 15:15:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot with camera (2.85 MB, image/jpeg)
2010-07-31 06:04 UTC, Daniel Rowe
no flags Details
Another screen shot with camera (3.40 MB, image/jpeg)
2010-07-31 06:08 UTC, Daniel Rowe
no flags Details
lspci -vv (56.38 KB, text/plain)
2010-07-31 06:35 UTC, Daniel Rowe
no flags Details
Xorg log file (264.04 KB, application/octet-stream)
2010-07-31 06:35 UTC, Daniel Rowe
no flags Details

Description Daniel Rowe 2010-07-31 05:59:31 UTC
Description of problem:

I have an ATI 3870 running in Fedora 13 open source driver. Working well up to this morning.

When I run compiz the screen looks like it is upside down and strings back to front. Do a screen shot and it looks OK. Working OK in non compiz mode.

I have reset compiz to default settings and still doing it. Logged in as a different user and still same. Swap to a different 3870 card and still the same.

Very strange effect........

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.13.0-1.fc13.x86_64
mesa-libGLU-7.8.1-6.fc13.x86_64
mesa-libGL-devel-7.8.1-6.fc13.x86_64
mesa-dri-drivers-7.8.1-6.fc13.x86_64
mesa-libGLU-devel-7.8.1-6.fc13.x86_64
mesa-libGL-7.8.1-6.fc13.x86_64
compiz-fusion-gnome-0.8.6-1.fc13.x86_64
compiz-fusion-extras-0.8.6-1.fc13.x86_64
libcompizconfig-devel-0.8.4-2.fc13.x86_64
libcompizconfig-0.8.4-2.fc13.x86_64
compiz-devel-0.8.6-1.fc13.x86_64
compiz-fusion-0.8.6-1.fc13.x86_64
compiz-bcop-0.8.4-1.fc13.noarch
compizconfig-python-0.8.4-1.fc13.x86_64
compiz-fusion-unsupported-0.8.4-3.fc13.x86_64
compiz-0.8.6-1.fc13.x86_64
compiz-fusion-devel-0.8.6-1.fc13.x86_64
compiz-gnome-0.8.6-1.fc13.x86_64
compiz-fusion-unsupported-gnome-0.8.4-3.fc13.x86_64
compiz-fusion-extras-gnome-0.8.6-1.fc13.x86_64


How reproducible:

Every time.

Steps to Reproduce:
1. Log into X
2. Start compiz
  
Actual results:

Screen very strange effect.

Expected results:

Works as expected.

Additional info:

The only updates which happen on this system are:

Jul 30 23:04:35 bajor yum: Updated: evolution-2.30.2-4.fc13.x86_64
Jul 30 23:04:35 bajor yum: Updated: smc-fonts-common-4.4-1.fc13.noarch
Jul 30 23:04:38 bajor yum: Updated: python-virtinst-0.500.3-4.fc13.noarch
Jul 30 23:04:51 bajor yum: Updated: virt-manager-0.8.4-2.fc13.noarch
Jul 30 23:04:53 bajor yum: Updated: smc-meera-fonts-4.4-1.fc13.noarch
Jul 30 23:04:59 bajor yum: Updated: evolution-help-2.30.2-4.fc13.noarch

Can't see that any of these would cause this issue.

Comment 1 Daniel Rowe 2010-07-31 06:04:14 UTC
Created attachment 435726 [details]
Screen shot with camera

Screen shot taken with camera.

Comment 2 Daniel Rowe 2010-07-31 06:08:13 UTC
Created attachment 435727 [details]
Another screen shot with camera

Another screen shot with camera

Comment 3 Daniel Rowe 2010-07-31 06:35:22 UTC
Created attachment 435728 [details]
lspci -vv

Comment 4 Daniel Rowe 2010-07-31 06:35:53 UTC
Created attachment 435729 [details]
Xorg log file

Comment 5 Daniel Rowe 2010-07-31 15:15:50 UTC
Not a bug. Screwed up GL libs.


Note You need to log in before you can comment on or make changes to this bug.