Bug 619985 - Permission problems while upgrading mkinitrd online
Permission problems while upgrading mkinitrd online
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-31 02:57 EDT by Răzvan Sandu
Modified: 2011-10-21 19:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 19:19:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2010-07-31 02:57:37 EDT
Description of problem:

On a freshly-installed CentOS 5.5 (i386) system, with all online upgrades as of July 30, 2010, *some* packages refuses to upgrade via yum. They seem to be related to mkinitrd.

device-mapper-multipath-0.4.7-34.el5_5.4.i386.rpm
glibc-2.5-49.el5_5.4.i686.rpm
glibc-common-2.5-49.el5_5.4.i386.rpm
kpartx-0.4.7-34.el5_5.4.i386.rpm
lvm2-2.02.56-8.el5_5.6.i386.rpm
mkinitrd-5.1.19.6-61.el5_5.2.i386.rpm
nash-5.1.19.6-61.el5_5.2.i386.rpm


While trying a:

yum -y upgrade

I get:


Transaction Summary
================================================================================
Install       6 Package(s)
Upgrade       1 Package(s)

Total download size: 29 M
Downloading Packages:
(1/7): kpartx-0.4.7-34.el5_5.4.i386.rpm                  | 420 kB     00:00     
(2/7): mkinitrd-5.1.19.6-61.el5_5.2.i386.rpm             | 467 kB     00:00     
(3/7): nash-5.1.19.6-61.el5_5.2.i386.rpm                 | 1.1 MB     00:00     
(4/7): lvm2-2.02.56-8.el5_5.6.i386.rpm                   | 2.6 MB     00:00     
(5/7): device-mapper-multipath-0.4.7-34.el5_5.4.i386.rpm | 2.8 MB     00:00     
(6/7): glibc-2.5-49.el5_5.4.i686.rpm                     | 5.3 MB     00:00     
(7/7): glibc-common-2.5-49.el5_5.4.i386.rpm              |  16 MB     00:02     
--------------------------------------------------------------------------------
Total                                           6.7 MB/s |  29 MB     00:04     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : glibc-common                                             1/8 
Error unpacking rpm package glibc-common-2.5-49.el5_5.4.i386
error: unpacking of archive failed on file /usr/sbin/build-locale-archive;4c53c885: cpio: open
  Installing     : nash                                                     2/8 
Error unpacking rpm package nash-5.1.19.6-61.el5_5.2.i386
error: unpacking of archive failed on file /sbin/nash;4c53c885: cpio: open
  Installing     : glibc                                                    3/8 
Error unpacking rpm package glibc-2.5-49.el5_5.4.i686
warning: /etc/localtime created as /etc/localtime.rpmnew
error: unpacking of archive failed on file /sbin/ldconfig;4c53c885: cpio: open
  Installing     : kpartx                                                   4/8 
Error unpacking rpm package kpartx-0.4.7-34.el5_5.4.i386
error: unpacking of archive failed on file /sbin/kpartx;4c53c885: cpio: open
  Installing     : device-mapper-multipath                                  5/8 
Error unpacking rpm package device-mapper-multipath-0.4.7-34.el5_5.4.i386
error: unpacking of archive failed on file /sbin/cciss_id;4c53c885: cpio: open
  Installing     : lvm2                                                     6/8 
Error unpacking rpm package lvm2-2.02.56-8.el5_5.6.i386
error: unpacking of archive failed on file /sbin/lvm;4c53c885: cpio: symlink
  Updating       : mkinitrd                                                 7/8 
Error unpacking rpm package mkinitrd-5.1.19.6-61.el5_5.2.i386
error: unpacking of archive failed on file /sbin/grubby;4c53c885: cpio: open

Failed:
  device-mapper-multipath.i386 0:0.4.7-34.el5_5.4                               
  glibc.i686 0:2.5-49.el5_5.4                                                   
  glibc-common.i386 0:2.5-49.el5_5.4                                            
  kpartx.i386 0:0.4.7-34.el5_5.4                                                
  lvm2.i386 0:2.02.56-8.el5_5.6                                                 
  mkinitrd.i386 0:5.1.19.6-61.el5_5.2                                           
  nash.i386 0:5.1.19.6-61.el5_5.2              


Version-Release number of selected component (if applicable):
Please see above.


  
Actual results:
The above packages won't upgrade by performing yum -y upgrade. Other packages *do* upgrade.

Expected results:
All packages should upgrade normally.
Comment 1 Răzvan Sandu 2010-08-06 03:29:58 EDT
I appologize, the cause was a hardware problem (failing HDD).

I would close this, but bugzilla doesn't allow me to.

Note You need to log in before you can comment on or make changes to this bug.