Bug 62011 - specifying mulitple relocations does not work
specifying mulitple relocations does not work
Status: CLOSED DUPLICATE of bug 67596
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 12:58 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 12:58:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-26 12:58:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
Specifying multiple relocations results in only the last --relocate substitution
being processed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Make a package with multiple prefix statments
2.try installing it specifying more than one --relocate option

	

Actual Results:  Note the two relocations:


[hoffman@thebes]rpms-7.2>rpm -qip apiary-themes-2.1-2.linux-noarch.rpm 
Name        : apiary-themes                Relocations: /home/hive/themes
/home/hive/html/images 
Version     : 2.1                               Vendor: Acxiom Corporation
Release     : 2                             Build Date: Tue 26 Mar 2002 11:15:04
AM CST
Install date: (not installed)               Build Host: redtux.conway.acxiom.com
Group       : HIVE                          Source RPM: apiary-themes-2.1-2.src.rpm
Size        : 5616690                          License: Acxiom Corporation, 2001
Packager    : Doug L. Hoffman <dohoff@dlhoffman.com>
URL         : http://devcentral.conway.acxiom.com
Summary     : Apiary Web Interface Themes

Now note the debug output: the individual relocations work fine...

Relocation #1:

[hoffman@babylon]rpms-7.2>rpm -Uvvh --test --nodeps  --relocate
/home/hive/themes=/home/dohoff/themes apiary-themes-2.1-2.linux-noarch.rpm 
 {cruft deleted}


D: getting list of mounted filesystems
D: ========== relocations
D:     0 relocate /home/hive/themes -> /home/dohoff/themes
D: relocating /home/hive/themes to /home/dohoff/themes
D: relocating directory /home/hive/themes/ to /home/dohoff/themes/
Preparing...                D: opening  db index       /var/lib/rpm/Basenames
rdonly mode=0x0

Relocation #2:

[hoffman@babylon]rpms-7.2>rpm -Uvvh --test  --relocate
/home/hive/themes=/home/dohoff/themes apiary-themes-2.1-2.linux-noarch.rpm 


D: ========== relocations
D:     0 relocate /home/hive/html/images -> /home/dohoff/images
D: relocating /home/hive/html/images to /home/dohoff/images
D: relocating directory /home/hive/html/images/xbox/ to /home/dohoff/images/xbox/
D: relocating directory /home/hive/html/images/starscape/ to
/home/dohoff/images/starscape/
D: relocating directory /home/hive/html/images/ringwraiths/ to
/home/dohoff/images/ringwraiths/
D: relocating directory /home/hive/html/images/nascar/ to
/home/dohoff/images/nascar/
D: relocating directory /home/hive/html/images/mushrooms/ to
/home/dohoff/images/mushrooms/
D: relocating directory /home/hive/html/images/hydra/ to /home/dohoff/images/hydra/
D: relocating directory /home/hive/html/images/hoth/ to /home/dohoff/images/hoth/
D: relocating directory /home/hive/html/images/harley/ to
/home/dohoff/images/harley/
D: relocating directory /home/hive/html/images/ferrari/ to
/home/dohoff/images/ferrari/
D: relocating directory /home/hive/html/images/enlightenment/ to
/home/dohoff/images/enlightenment/
D: relocating directory /home/hive/html/images/egypt/ to /home/dohoff/images/egypt/
D: relocating directory /home/hive/html/images/devcentral/ to
/home/dohoff/images/devcentral/
D: relocating directory /home/hive/html/images/deltablue/ to
/home/dohoff/images/deltablue/
D: relocating directory /home/hive/html/images/Tropic/ to
/home/dohoff/images/Tropic/
D: relocating directory /home/hive/html/images/LOTR/ to /home/dohoff/images/LOTR/
Preparing...                D: opening  db index       /var/lib/rpm/Basenames
rdonly mode=0x0

Now note the result with both relocations:


[hoffman@babylon]rpms-7.2>rpm -Uvvh --test --nodeps  --relocate
/home/hive/html/images=/home/dohoff/images --relocate
/home/hive/themes=/home/dohoff/themes apiary-themes-2.1-2.linux-noarch.rpm 

{more cruft deleted}

D: getting list of mounted filesystems
D: ========== relocations
D:     0 relocate /home/hive/themes -> /dohoff/themes
D:     1 relocate /home/hive/themes -> /home/dohoff/themes
D: relocating /home/hive/themes to /home/dohoff/themes
D: relocating directory /home/hive/themes/ to /home/dohoff/themes/
Preparing...                D: opening  db index       /var/lib/rpm/Basenames
rdonly mode=0x0

Only the last relocation option specified works, contrary to the supplied
documentation.



Expected Results:  Both relocations should be processed correctly.

Additional info:
Comment 1 Jeff Johnson 2002-06-28 12:09:58 EDT

*** This bug has been marked as a duplicate of 67596 ***

Note You need to log in before you can comment on or make changes to this bug.