Bug 62012 - Installing the dev package, /dev/logi* files are missing
Summary: Installing the dev package, /dev/logi* files are missing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-03-26 18:25 UTC by Forrest
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 16:23:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Forrest 2002-03-26 18:25:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
After installation of the dev package, /dev/logi* (/dev/logibm, /dev/logimouse,
etc.) files have a semicolon followed by 8 alphanumeric characters which
correspond to the file hash used to verify each file.  `rpm -Uvv --force
dev-3.2-12.i386.rpm` showed that the hash and the file name match (i.e.
/dev/logibm;3ca0b332).  I am hypothesizing that this is rpm, because the same
thing happened on my 7.2 machine when I upgraded to the new rpm updates.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install dev with rpm-4.0.4-7x*
2.  rpm -V dev shows /dev/logi* missing (unless it was an upgrade, in which case
the original /dev/logi* files remain)
	

Actual Results:  /dev/logi* files were 'missing' according to rpm -V, and they
have alphanumeric characters appended to the file name.

Expected Results:  /dev/logi* should not have anything appended to the file name.

Additional info:

Comment 1 Bill Nottingham 2002-03-26 20:04:30 UTC
Are there errors in the install.log or upgrade.log?

Comment 2 Bill Nottingham 2002-03-26 20:05:51 UTC
Are there errors in the install.log or upgrade.log?

Comment 3 Forrest 2002-03-26 20:43:36 UTC
No.  `grep -v Installing /tmp/install.log` yeilds nothing.  The file contains an
entry for dev-3.2-12, but no errors.

Comment 4 Nalin Dahyabhai 2002-03-27 16:17:15 UTC
I straced a "rpm -Uvh --force" of this package, looking for mknod() and rename()
syscalls, and saw a mostly 1:1 match, except for the nodes where we get this
(rename() was not called, leaving it with the temporary device node's name).

Comment 5 Jeff Johnson 2002-03-27 16:23:01 UTC
There's an errant strcmp in lib/fsm.c that avoids
creating sockets that never should have been put
into the dev package.

Comment 6 Jeff Johnson 2002-03-27 19:34:12 UTC
Fixed in rpm-4.0.4-7x.9.


Note You need to log in before you can comment on or make changes to this bug.