Bug 620137 - Use python's built-in uuid impl instead of our custom one
Summary: Use python's built-in uuid impl instead of our custom one
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm   
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Saggi Mizrahi
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Keywords: CodeChange, Improvement
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-01 07:40 UTC by Saggi Mizrahi
Modified: 2016-04-18 06:34 UTC (History)
6 users (show)

Fixed In Version: vdsm-4.9-14.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-19 15:06:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Saggi Mizrahi 2010-08-01 07:40:43 UTC
Description of problem:
In python 2.6 there the uuid module was introduced.
There is no reason why we should maintain our own implementation.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Saggi Mizrahi 2010-08-01 07:42:47 UTC
For QA:
There isn't anything specific to test. These changes are only internal and are supposed to be transparent system wide. This change does not add or remove any VDSM functionality.

Comment 2 Yaniv Kaul 2010-08-01 07:47:12 UTC
(In reply to comment #1)
> For QA:
> There isn't anything specific to test. These changes are only internal and are
> supposed to be transparent system wide. This change does not add or remove any
> VDSM functionality.    

Set 'CodeChange' keyword.

Comment 5 yeylon@redhat.com 2010-09-20 13:34:58 UTC
vdsm-4.9-16.el6.x86_64

looks like the UUID is being generated with no difference then before.


Note You need to log in before you can comment on or make changes to this bug.