Red Hat Bugzilla – Bug 620217
hplip-libs-3.10.6-1.fc14.x86_64 requires python(abi) = 2.6
Last modified: 2010-12-13 12:24:58 EST
Description of problem:
Didn't see it listed on the Rawhide/Broken Deps list
Version-Release number of selected component (if applicable):
Steps to Reproduce:
Maybe just needs a rebuild?
hplip-libs-3.10.5-8.fc14.x86_64 "works for me", but hplip-libs-3.10.6-1.fc14.x86_64 does not.
I found 'libselinux-python-2.0.96-4.fc14' had a similar issue: earlier build had 'python(abi) = 2.7', but later build had 'python(abi) = 2.6'.
(In reply to comment #1)
> Maybe just needs a rebuild?
Ah, didn't understand the comment.
I've rebuilt hplip-3.10.6-1.fc15.x86_64 (and friends) locally, on a system that is now fully updated to python-2.7. Here is what I get for the locally built hplip-libs. It says 'requires python(abi) = 2.7':
[tbl@tlondon x86_64]$ rpm -q --requires --package hplip-libs-3.10.6-1.fc15.x86_64.rpm
hplip-common = 3.10.6-1.fc15
python(abi) = 2.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Could this indicate the koji package was built with python-2.6 (or some such build miscue)?