Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620217 - hplip-libs-3.10.6-1.fc14.x86_64 requires python(abi) = 2.6
hplip-libs-3.10.6-1.fc14.x86_64 requires python(abi) = 2.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 11:42 EDT by Tom London
Modified: 2010-12-13 12:24 EST (History)
2 users (show)

See Also:
Fixed In Version: hplip-3.10.9-8.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 12:24:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2010-08-01 11:42:58 EDT
Description of problem:
Didn't see it listed on the Rawhide/Broken Deps list

Version-Release number of selected component (if applicable):
hplip-libs-3.10.6-1.fc14.x86_64

How reproducible:
Yup

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2010-08-02 11:30:58 EDT
Maybe just needs a rebuild?
Comment 2 Tom London 2010-08-02 11:52:39 EDT
hplip-libs-3.10.5-8.fc14.x86_64 "works for me", but hplip-libs-3.10.6-1.fc14.x86_64 does not.

I found 'libselinux-python-2.0.96-4.fc14' had a similar issue: earlier build had 'python(abi) = 2.7', but later build had 'python(abi) = 2.6'.
Comment 3 Tom London 2010-08-02 14:23:11 EDT
(In reply to comment #1)
> Maybe just needs a rebuild?    

Ah, didn't understand the comment.

I've rebuilt hplip-3.10.6-1.fc15.x86_64 (and friends) locally, on a system that is now fully updated to python-2.7.  Here is what I get for the locally built hplip-libs.  It says 'requires python(abi) = 2.7':

[tbl@tlondon x86_64]$ rpm -q --requires --package hplip-libs-3.10.6-1.fc15.x86_64.rpm 
hplip-common = 3.10.6-1.fc15
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.11)(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
libcrypto.so.10()(64bit)  
libcups.so.2()(64bit)  
libhpip.so.0()(64bit)  
libhpmud.so.0()(64bit)  
libm.so.6()(64bit)  
libm.so.6(GLIBC_2.2.5)(64bit)  
libnetsnmp.so.20()(64bit)  
libpthread.so.0()(64bit)  
libpthread.so.0(GLIBC_2.2.5)(64bit)  
libpthread.so.0(GLIBC_2.3.2)(64bit)  
libsane.so.1()(64bit)  
libusb-0.1.so.4()(64bit)  
python(abi) = 2.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
rpmlib(PayloadIsXz) <= 5.2-1
[tbl@tlondon x86_64]$ 

Could this indicate the koji package was built with python-2.6 (or some such build miscue)?

Note You need to log in before you can comment on or make changes to this bug.