Bug 620250 - Either virsh list or virsh -c xen:/// list shows Domain-0 on a Xen Hypervisor Ubuntu OS
Summary: Either virsh list or virsh -c xen:/// list shows Domain-0 on a Xen Hypervisor...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt   
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-01 18:58 UTC by Henrik Bach
Modified: 2016-04-14 19:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-14 19:40:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Bach 2010-08-01 18:58:22 UTC
Description of problem:
Either virsh list or virsh -c xen:/// list shows Domain-0 on a Xen Hypervisor Ubuntu OS.

Version-Release number of selected component (if applicable):
$ virsh version
Compiled against library: libvir 0.7.5
Using library: libvir 0.7.5
Using API: QEMU 0.7.5
Running hypervisor: QEMU 0.12.3

virsh -c xen:/// version
Compiled against library: libvir 0.7.5
Using library: libvir 0.7.5
Using API: Xen 3.0.1
Running hypervisor: Xen 4.0.0

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:

sudo virsh list
 Id Name                 State
----------------------------------

sudo virsh -c xen:/// list
 Id Name                 State
----------------------------------

sudo xm list
Name                                        ID   Mem VCPUs      State   Time(s)
Domain-0                                     0  1017     2     r-----   2147.0

Expected results:

sudo virsh list
 Id Name                 State
----------------------------------
0 Domain-0               running


Additional info:
Due to Ubuntu doesn't supply a Xen image it is built from pre-scriptions from the internet.

uname -rm
2.6.32.10 i686

Comment 1 Cole Robinson 2016-04-14 19:40:18 UTC
Sorry this never received a timely response. FWIW nowadays the libxl libvirt driver doesn't even seem to show domain-0 on fedora, and hasn't for a long time, so I suspect this is intentional


Note You need to log in before you can comment on or make changes to this bug.