Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620359 - Intel Firmware RAID no longer works!
Intel Firmware RAID no longer works!
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 06:17 EDT by Hans de Goede
Modified: 2010-11-10 14:52 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:52:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda logfiles (from report) (183.49 KB, text/plain)
2010-08-02 06:17 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2010-08-02 06:17:46 EDT
Created attachment 435993 [details]
anaconda logfiles (from report)

Due to a change in the mdadm cmdline syntax Intel Firmware RAID no longer works, see the attached anaconda-tb report, at line 811:
WARNING : failed to add member /dev/sdb to md array /dev/md0: mdadd failed for /dev/sdb: 10:13:13,953 ERROR   : mdadm:option --no-degraded not valid in incremental mode

Note this *MUST* be fixed before 6.0 but I seem unable to set the 6.0.0 flag to ? anymore.

Note to QA: this can be reproduced by installing RHEL6.0-20100730.5 on any machine with Intel Firmware RAID, with the end result being that the RAID set is not recognized / available for installation after the filter UI.
Comment 1 Hans de Goede 2010-08-03 02:50:58 EDT
A patch has been posted to a-d-l and reviewed. I've verified that this patch fixes Intel Firmware RAID with:
http://download.devel.redhat.com/rel-eng/RHEL6.0-20100730.5/6/Workstation/i386/os
+ an updates.img with the patch.
Comment 5 releng-rhel@redhat.com 2010-11-10 14:52:33 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.