Bug 620362 - Service rdma is not LSB-compliant - no pid file
Summary: Service rdma is not LSB-compliant - no pid file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdma   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: RHELNAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-02 10:35 UTC by Caspar Zhang
Modified: 2013-07-03 07:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 13:36:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Caspar Zhang 2010-08-02 10:35:24 UTC
Description of problem:

I'm not quiet sure about whether a pid file is necessary in a running service, but since I followed the testing steps in BaseOS's InitScript testing wiki, I found that rdma doesn't have a pid file when service running. See this beaker link: https://beaker.engineering.redhat.com/jobs/10079 , in more detail, here: https://beaker.engineering.redhat.com/logs/2010/79/10079/18344/220165/605456///test_log-rdma-is-stopped-pid-file-exists.log

The corresponding code in tests/rdma/Sanity/initscript is:

SERVICE=rdma
<snip>
rlServiceStart $SERVICE
rlAssertExists "/var/run/$SERVICE.pid" "Pid file /var/run/$SERVICE.pid must exist"

Version-Release number of selected component (if applicable):
rdma-1.0-7.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2010-08-02 11:08:08 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Doug Ledford 2010-08-02 13:36:24 UTC
NOTABUG.  There is no daemon, and therefore no pid file to create.  The status portion of the rdma service is determined entirely by checking which kernel modules are loaded into the running kernel.  Furthermore, the rdma service doesn't even create a definable thread in the kernel when the modules are loaded, so it's not like we could hijack a kernel thread pid number for the purposes you requested. I think you'll just need to give the rdma service a pass on this test in your test framework. (But confirm with notting)


Note You need to log in before you can comment on or make changes to this bug.