Bug 620467 - Rescue mode does not find an installation on Intel BIOS RAID
Rescue mode does not find an installation on Intel BIOS RAID
Status: CLOSED DUPLICATE of bug 620745
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 11:41 EDT by Hans de Goede
Modified: 2010-08-11 11:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 11:36:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (3.96 KB, text/plain)
2010-08-02 11:41 EDT, Hans de Goede
no flags Details
program.log (10.76 KB, text/plain)
2010-08-02 11:42 EDT, Hans de Goede
no flags Details
storage.log (82.29 KB, text/plain)
2010-08-02 11:42 EDT, Hans de Goede
no flags Details
syslog (58.25 KB, text/plain)
2010-08-02 11:42 EDT, Hans de Goede
no flags Details
/etc/fstab (860 bytes, text/plain)
2010-08-02 14:35 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2010-08-02 11:41:03 EDT
Created attachment 436054 [details]
anaconda.log

To reproduce:
-do a default autopart install on an Intel BIOS RAID mirror
-start the installer in rescue mode, and let it try to automount the existing
 install

Result:
-fails to find the existing install

Further info:
-logs attached
Comment 1 Hans de Goede 2010-08-02 11:42:06 EDT
Created attachment 436055 [details]
program.log
Comment 2 Hans de Goede 2010-08-02 11:42:25 EDT
Created attachment 436056 [details]
storage.log
Comment 3 Hans de Goede 2010-08-02 11:42:49 EDT
Created attachment 436057 [details]
syslog
Comment 5 RHEL Product and Program Management 2010-08-02 12:07:48 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Brian Lane 2010-08-02 13:01:04 EDT
What does /etc/fstab look like?
Comment 7 Hans de Goede 2010-08-02 14:35:07 EDT
Created attachment 436089 [details]
/etc/fstab
Comment 8 David Lehman 2010-08-02 14:53:59 EDT
15:13:49,515 DEBUG   : PV md127p2 has no vg_name
15:13:49,515 DEBUG   : PV md127p2 has no vg_uuid

So, according to udev/lvm, there is no VG metadata in the PV, which of course means we do not ever assemble the LVs and find the installation.
Comment 9 Hans de Goede 2010-08-03 07:55:49 EDT
The root cause for this lies in lvm, see bug 620745. I'm testing a workaround patch now.
Comment 10 Hans de Goede 2010-08-03 08:24:48 EDT
A workaround patch has been posted to a-d-l. I've verified that this patch fixes the finding of a default Intel Firmware RAID install in rescue mode with:
http://download.devel.redhat.com/rel-eng/RHEL6.0-20100730.5/6/Workstation/i386/os
+ an updates.img with the patch.
Comment 11 Hans de Goede 2010-08-11 11:36:35 EDT
The lvm team has a fix for this, marking this bug as a duplicate of the lvm bug 620745.

*** This bug has been marked as a duplicate of bug 620745 ***

Note You need to log in before you can comment on or make changes to this bug.