Bug 620474 - kdump service fails to start
kdump service fails to start
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cong Wang
Red Hat Kernel QE team
: Reopened, RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 11:54 EDT by michal novacek
Modified: 2013-09-29 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 10:17:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michal novacek 2010-08-02 11:54:33 EDT
Description of problem: 
kdump service will not start.


Version-Release number of selected component (if applicable):
rhel6, kernel 2.6.32-44.el6.x86_64
kexec-tools-2.0.0-94.el6.x86_64

How reproducible: always

Steps to Reproduce:
1. boot rhel6 with added "crashkernel=128M@16M" parameter to kernel command line
2. run: /etc/init.d/kdump restart

  
Actual results: failure of the script

Expected results: success. 

Additional info:
my guess is that there is a change in the way how to know whether the parameter was specified on kernel command line.

# uname -r
2.6.32-44.el6.x86_64

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)

# cat /proc/cmdline 
ro root=/dev/mapper/vg_dellpe86001-lv_root rd_LVM_LV=vg_dellpe86001/lv_root rd_LVM_LV=vg_dellpe86001/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us console=ttyS0,115200 crashkernel=128M@16M

# /etc/init.d/kdump restart
Memory for crashkernel is not reserved
Please reserve memory by passing "crashkernel=X@Y" parameter to the kernel
Stopping kdump:                                            [FAILED]
Starting kdump:                                            [FAILED]

# tail /var/log/messages
Aug  2 11:41:42 dell-pe860-01 init: prefdm main process ended, respawning
Aug  2 11:41:42 dell-pe860-01 init: prefdm main process (2057) terminated with status 1
Aug  2 11:41:42 dell-pe860-01 init: prefdm main process ended, respawning
Aug  2 11:41:42 dell-pe860-01 init: prefdm main process (2074) terminated with status 1
Aug  2 11:41:42 dell-pe860-01 init: prefdm respawning too fast, stopped
Aug  2 11:41:42 dell-pe860-01 ntpd[1682]: Listening on interface #7 virbr0, 192.168.122.1#123 Enabled
Aug  2 11:42:44 dell-pe860-01 kdump: kexec: failed to unload kdump kernel
Aug  2 11:42:44 dell-pe860-01 kdump: failed to stop
Aug  2 11:42:44 dell-pe860-01 kdump: No crashkernel parameter specified for running kernel
Aug  2 11:42:44 dell-pe860-01 kdump: failed to start up

# cat /sys/kernel/kexec_crash_size
0
Comment 2 RHEL Product and Program Management 2010-08-02 12:27:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Cong Wang 2010-08-02 21:24:33 EDT
This is not a bug, your kernel failed to find a 128M hole at 16M, thus no memory is reserved. You should try to use 128M@0 to let the kernel to find a base address.
Comment 4 michal novacek 2010-08-19 11:00:15 EDT
Works well. Two questions though before you close it:
 1] is kdump script supposed to work with "crashkernel=auto" parameter? If it is it does not, saying that you have not passed "crashkernel=X@Y".
 2] how do I tell correct value? the only source of information I found is the /usr/share/doc/*/ howto that does not give the explanation. it only tells you that you should give "128M@16M" for i386 and x86_64.
Comment 5 Cong Wang 2010-08-19 22:40:22 EDT
(In reply to comment #4)
> Works well. Two questions though before you close it:
>  1] is kdump script supposed to work with "crashkernel=auto" parameter? If it
> is it does not, saying that you have not passed "crashkernel=X@Y".


kdump will not see "crashkernel=auto", it will see the actual number in /proc/cmdline.

>  2] how do I tell correct value? the only source of information I found is the
> /usr/share/doc/*/ howto that does not give the explanation. it only tells you
> that you should give "128M@16M" for i386 and x86_64.

There is no one true way, this is why "crashkernel=auto" gets introduced. Usually you can try 128M@0 or 256M@0 for x86 machines.

Note You need to log in before you can comment on or make changes to this bug.