Bug 620536 - gnome-appearance-properties disappeared with no readily apparent replacement
gnome-appearance-properties disappeared with no readily apparent replacement
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 15:25 EDT by Gene Snider
Modified: 2010-08-18 21:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnome-panel-2.31.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Snider 2010-08-02 15:25:56 EDT
Description of problem:
gnome-appearance-properties appears to have been removed from control-center-2.31.5-2.fc14.  The executable and .desktop files were removed from the spec file for this version.  Are there any plans to replace it, or will users be forced to use gconf-editor to change desktop backgrounds, themes, and fonts?  If there is already a replacement along the lines of "gnome-control-center sound" and "gnome-control-center power", what is it?  Clicking the "Change Desktop Background" menu item after right clicking the desktop fails silently.

Version-Release number of selected component (if applicable):
2.31.5-2.fc14

How reproducible:
Easily.

Steps to Reproduce:
1. Update.
2.
3.
  
Actual results:
Unable to start gnome-appearance-properties.

Expected results:
The old application or a replacement should be available.

Additional info:
Comment 1 Gene Snider 2010-08-05 14:36:08 EDT
I see a new control-center was pushed to updates-testing.  However, it won't install because of the following dependency issues:

--> Finished Dependency Resolution
Error: Package: gnome-media-2.31.5-4.fc14.x86_64 (@rawhide)
           Requires: libgnome-control-center.so.1()(64bit)
           Removing: 1:control-center-2.31.5-2.fc14.x86_64 (@rawhide)
               libgnome-control-center.so.1()(64bit)
           Updated By: 1:control-center-2.31.6-1.fc14.x86_64 (updates-testing)
               Not found
Error: Package: gnome-packagekit-2.31.4-2.fc14.x86_64 (@fedora)
           Requires: libgnome-control-center.so.1()(64bit)
           Removing: 1:control-center-2.31.5-2.fc14.x86_64 (@rawhide)
               libgnome-control-center.so.1()(64bit)
           Updated By: 1:control-center-2.31.6-1.fc14.x86_64 (updates-testing)
               Not found
Error: Package: gnome-bluetooth-2.90.0-4.fc14.x86_64 (@rawhide)
           Requires: libgnome-control-center.so.1()(64bit)
           Removing: 1:control-center-2.31.5-2.fc14.x86_64 (@rawhide)
               libgnome-control-center.so.1()(64bit)
           Updated By: 1:control-center-2.31.6-1.fc14.x86_64 (updates-testing)
               Not found
Error: Package: gnome-color-manager-2.31.4-1.fc14.x86_64 (@rawhide)
           Requires: libgnome-control-center.so.1()(64bit)
           Removing: 1:control-center-2.31.5-2.fc14.x86_64 (@rawhide)
               libgnome-control-center.so.1()(64bit)
           Updated By: 1:control-center-2.31.6-1.fc14.x86_64 (updates-testing)
               Not found
Error: Package: gnome-power-manager-2.31.4-1.fc14.x86_64 (@rawhide)
           Requires: libgnome-control-center.so.1()(64bit)
           Removing: 1:control-center-2.31.5-2.fc14.x86_64 (@rawhide)
               libgnome-control-center.so.1()(64bit)
           Updated By: 1:control-center-2.31.6-1.fc14.x86_64 (updates-testing)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Using --skip-broken doesn't work, but two of the packages are already rebuilt and residing in koji.  Those two are:
gnome-bluetooth-2.31.6-1.fc14.x86_64.rpm and
gnome-media-2.31.6-1.fc14.x86_64.rpm

However, gnome-color-manager, gnome-packagekit, and gnome-power-manager have not been rebuilt against the new control-center libgnome-control-center.so.  I'm unable to test the new/old gnome-appearance-properties until this is fixed.

Thanks,
Gene
Comment 2 Matthias Clasen 2010-08-13 14:13:05 EDT
The appearance capplet is back (for now)
Comment 3 Fedora Update System 2010-08-13 14:13:43 EDT
brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14
Comment 4 Fedora Update System 2010-08-16 12:04:57 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, file-roller-2.31.5-2.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel totem-pl-parser brasero dconf devhelp epiphany evince file-roller gedit glib2 gnome-bluetooth gnome-user-share gobject-introspection nautilus-sendto seahorse-plugins totem rhythmbox sound-juicer yelp gnome-media'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14,totem-pl-parser-2.30.2-1.fc14
Comment 5 Gene Snider 2010-08-16 20:24:22 EDT
Everything is back to normal, so close this one?

Thanks,
Gene
Comment 6 Fedora Update System 2010-08-18 21:19:50 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, file-roller-2.31.90-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.