Bug 620613 - ntpd man page doesn't explain "-L interface" usage
Summary: ntpd man page doesn't explain "-L interface" usage
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ntp (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords: ManPageChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-03 02:17 UTC by masanari iida
Modified: 2010-12-03 11:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 11:50:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description masanari iida 2010-08-03 02:17:39 UTC
Description of problem:
ntpd man page is out of sync.

Version-Release number of selected component (if applicable):
ntp-4.2.4p8-2.el6.i686 (from RHEL6 beta2)

How reproducible:
Always

Symptom:
Since ntpd-4.2.2, we can specify which interface not to listen
using -L [interface].

# ntpd -L
ntpd: option requires argument -L
usage: ntpd [ -46abdgnqx ] [ -c config_file ]
                [ -f drift_file ] [ -k key_file ] [ -l log_file ]
                [ -p pid_file ] [ -r broadcast_delay ] [ -s stats_dir ]
                [ -t trusted_key ] [ -v sys_var ] [ -V default_sysvar ]
                [ -L [ interface ] ]              <=
                [ -P fixed_process_priority ]
                [ -u user[:group] ] [ -i jaildir ]
#

But online manual of the ntpd didn't explain about this.

       -L      Do not listen to virtual IPs. The default is to listen

Additional info:
Same issue exist on RHEL5 (BZ#619717)

Comment 2 RHEL Product and Program Management 2010-08-03 02:47:51 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Miroslav Lichvar 2010-12-03 11:50:10 UTC
In ntp-4.2.4 the -L option doesn't accept an argument, there is a new option -I to specify which interface it should listen on.

From ntpd -h output:

  Flg Arg Option-Name    Description
   -I Str interface      Listen on interface
   -L no  novirtualips   Do not listen to virtual IPs


Note You need to log in before you can comment on or make changes to this bug.