Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620622 - Beaker cannot install /kernel/errata/4.8.z from test repo.
Beaker cannot install /kernel/errata/4.8.z from test repo.
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.5
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Marian Csontos
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 22:55 EDT by Igor Zhang
Modified: 2010-08-03 02:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 01:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Zhang 2010-08-02 22:55:17 EDT
Description of problem:
When doing regression test for rhel-4.8.z, beaker cannot install /kernel/errata/4.8.z successfully from test repo. But rhts can do this.

In beaker:
https://beaker.engineering.redhat.com/jobs/8565
In rhts:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=168093


Version-Release number of selected component (if applicable):
Version - 0.5.51

How reproducible:
Seems always

Steps to Reproduce:
1. Submit the attached job to beaker
2. View the results

  
Actual results:
/kernel/errata/4.8.z install failed...

Expected results:
/kernel/errata/4.8.z install will succeeded.

Additional info:
Comment 1 Marian Csontos 2010-08-03 01:18:06 EDT
Apparently not all required tests (aka Tasks) are in beaker:

  https://beaker.engineering.redhat.com/logs/2010/65/8565/15256/185492/debug/task_beah_unexpected

This is not a bug. Use 

  bkr task-add ... 

or

  make bkradd
Comment 2 Igor Zhang 2010-08-03 01:44:02 EDT
(In reply to comment #1)
> Apparently not all required tests (aka Tasks) are in beaker:
> 
>  
> https://beaker.engineering.redhat.com/logs/2010/65/8565/15256/185492/debug/task_beah_unexpected
> 
> This is not a bug. Use 
> 
>   bkr task-add ... 
> 
> or
> 
>   make bkradd    

But I can find rh-tests-kernel-errata-4_8_z-1.1-16.noarch.rpm in "Task Library" from beaker web UI.
So you mean I need to readd it again?
Comment 3 Igor Zhang 2010-08-03 01:47:14 EDT
Here it's already in beaker:
https://beaker.engineering.redhat.com/tasks/1498
Comment 4 Marian Csontos 2010-08-03 02:02:02 EDT
Clarified on IRC:

> Error: Missing Dependency: rh-tests-super-smack is needed by package rh-tests-kernel-errata-4_8_z

This is the task which has to be added to beaker.
Comment 5 Igor Zhang 2010-08-03 02:09:01 EDT
Problems solved.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.