Bug 62070 - Installer will set keyboard layout under console as US not ET as expected.
Installer will set keyboard layout under console as US not ET as expected.
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 02:47 EST by Ivo Sarak
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 14:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-03-27 02:47:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
Under installer I choose an Estonian keyboard layout, but after installation
when I log in to console I will get an US keyboard layout.

How reproducible:
Didn't try


	
Actual Results:  Under console I get an US layout for keyboard.

Expected Results:  Under console I should get an Estonian layout for keyboard as
I selected when I installed Skipjack.

Additional info:

Estonian keyboard layout has been always broken under console regardless of
RedHat version. Please fix it for good...
Comment 1 Jeremy Katz 2002-04-01 18:37:00 EST
Added in CVS
Comment 2 Ivo Sarak 2002-04-02 11:16:05 EST
Does this mean that this problem is fixed?
Comment 3 Jay Turner 2002-04-05 13:32:04 EST
It means that we have a fix built in-house, but it hasn't been 
tested or released yet.
Comment 4 Michael Fulbright 2002-04-09 15:29:09 EDT
The installer is now correctly writing out the configuration, however there is
now a problem on boot because the et keymap is broken.

Error from running 'loadkeys et':

unknown keysym 'currency'
/lib/kbd/keymaps/i386/qwery/et.kmap.gz:5:parse error
syntax error in map file
key bindings now changed
Comment 5 Michael Fulbright 2002-04-09 15:29:42 EDT
Btw, the country code should be 'ee'.
Comment 6 Bernhard Rosenkraenzer 2002-04-15 09:46:05 EDT
Fixed in -39
Comment 7 Ivo Sarak 2002-04-19 03:06:51 EDT
Estonian keyboard support in Skipjack beta2 is even more broaken:
There is not possible to choose an Estonian keyboard at install time (text mode 
install) and if I change keyboard layout to Estonian after install, it will 
complain "Keymap  [FAILED]".
Comment 8 Bernhard Rosenkraenzer 2002-04-19 05:16:42 EDT
No longer a console-tools problem
Comment 9 Michael Fulbright 2002-05-24 12:39:28 EDT
Brent can you look at this as it relates to the new kbd config tool?
Comment 10 Brent Fox 2002-05-24 14:21:05 EDT
Sure.  I didn't have Estonian in my list, but I added it and I think it does the
correct thing.  By the "correct" thing, I mean that it edits the
/etc/sysconfig/keyboard and /etc/X11/XF86Config-4 files and then calls
'loadkeys' and 'setxkbmap' for the right keymap.  It works so far on my machine.

ivo, we're working on a new keyboard tool called redhat-config-keyboard that
should simplify getting the keymaps right, especially for non-us keyboards.  I
want to get the keyboard problem right once and for all.  It's not ready for
public consumption at the moment, but do you plan on testing the public beta
versions of the next Red Hat Linux release?  If so, I'd really appreciate it if
you could help us test this tool.
Comment 11 Ivo Sarak 2002-05-30 03:45:56 EDT
Yes, I will try the next RedHat Public Beta and if I can help to make this 
problem go away, I am happy to test this new tool.
Comment 12 Brent Fox 2002-06-28 17:50:45 EDT
Okay.  Thanks for your participation.  I'm going to close this bug report as
'Wontfix' since the code in question no longer exists in our latest internal
trees.  I believe that the bug does not occur in redhat-config-keyboard, but if
you find any bugs with the new keyboard tool, please open a new bug report
against it.  Thanks for your report.
Comment 13 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.