Bug 620782 - Compliance icon: throws segmentation fault upon right click.
Summary: Compliance icon: throws segmentation fault upon right click.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin   
(Show other bugs)
Version: 0.5
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords: QA-Closed
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-03 13:31 UTC by Sudhir D
Modified: 2015-05-14 15:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-04 14:48:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sudhir D 2010-08-03 13:31:06 UTC
Description of problem:
Right click on the compliance icon throws segmentation fault.

Version-Release number of selected component (if applicable):
subscription-manager-0.73-1.el6.x86_64.rpm


How reproducible:
Always

Steps to Reproduce:
1. force the compliance icon
2. right click on the icon

  
Actual results:
** (rhsm-compliance-icon:7202): CRITICAL **:
dbus_g_proxy_connect_signal: assertion `DBUS_IS_G_PROXY (proxy)' failed
** (rhsm-compliance-icon:7202): CRITICAL **:
dbus_g_proxy_connect_signal: assertion `DBUS_IS_G_PROXY (proxy)' failed
** (rhsm-compliance-icon:7202): CRITICAL **: dbus_g_proxy_call:
assertion `DBUS_IS_G_PROXY (proxy)' failed
** (rhsm-compliance-icon:7202): DEBUG: icon click detected
Segmentation fault (core dumped)

Expected results:
As discussed with James Bowes, Right click should do exactly as Left click, i.e., open up the sm-ui 

Additional info:

Comment 1 James Bowes 2010-08-03 19:19:03 UTC
I missed an api call to initialize libnotify. it worked without the call on F13, but not on older distros. My bad!

Comment 2 James Bowes 2010-08-03 19:29:38 UTC
should be fixed in subscription-manager-0.74-1

Comment 3 Sudhir D 2010-08-04 14:00:44 UTC
Verified against subscription-manager-0.74-1 and right click works same as left click.

Marking the bug verified.

Comment 4 John Sefler 2011-05-04 14:48:04 UTC
Group move of VERIFIED Entitlement/'client tools' component bugs to CLOSED CURRENT_RELEASE since these bugs have already been included in Alpha and Beta releases for Entitlements.

Going forward, the RHEL/subscription-manager component is a better classification for these types of bugs.


Note You need to log in before you can comment on or make changes to this bug.