Bug 620814 - udevd[369]: specified group 'floppy' unknown
Summary: udevd[369]: specified group 'floppy' unknown
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 624234 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-03 14:55 UTC by Jóhann B. Guðmundsson
Modified: 2010-08-24 01:32 UTC (History)
5 users (show)

Fixed In Version: udev-161-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 01:32:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2010-08-03 14:55:47 UTC
Description of problem:

Startup error msg from udev.

Version-Release number of selected component (if applicable):

160-8


How reproducible:

always

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:

The above error msg

Expected results:

no error msg at all

Additional info:

Comment 1 Harald Hoyer 2010-08-03 15:47:42 UTC
$ grep floppy /etc/group
floppy:x:19:

Hmm, this should be in setup-2.8.23-1.fc14.noarch a long time now..

Comment 2 Jóhann B. Guðmundsson 2010-08-03 17:35:33 UTC
There is no group entry for floppy in /etc/group. script failure? 

Adding the floppy group fixes this problem 

BTW did Kyle succeed in killing the floppy.. 

* Thu Aug 06 2009 Kyle McMartin <kyle@redhat.com> 2.6.31.0.133.rc5.git3 - die-floppy-die.patch: it's the 21st century, let's not rely on steam powered technology. 

;)

Comment 3 Harald Hoyer 2010-08-04 07:51:37 UTC
then reassign..

Comment 4 Jóhann B. Guðmundsson 2010-08-04 08:00:28 UTC
Your wish is my command...

Comment 5 Ondrej Vasik 2010-08-07 05:32:20 UTC
Reservation in uidgid file for group floppy (19) is done for packages dev/MAKEDEV. I don't think this should be created by default by setup - maybe udev is better idea - the same way it is done for groups dialout, cdrom, tape ... why not for floppy?

Comment 6 Jóhann B. Guðmundsson 2010-08-12 09:20:02 UTC
Harald ping. . .

Comment 7 Harald Hoyer 2010-08-12 09:37:11 UTC
well, then.. so be it..

Comment 8 Harald Hoyer 2010-08-12 09:54:02 UTC
So, should udev just check _every_ group it needs? Including "root", "tty", "lp", "disk", "kmem"?

Comment 9 Harald Hoyer 2010-08-12 09:54:28 UTC
forgot "video"

Comment 10 Ondrej Vasik 2010-08-12 10:42:40 UTC
You don't need to check for these - as setup already creates them - they are in the basic /etc/group provided by setup during installation and setup package is always on the system... 
I just don't want to add floppy group to default system groups (especially nowadays) ...

Comment 11 Harald Hoyer 2010-08-17 09:21:22 UTC
*** Bug 624234 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2010-08-17 09:44:14 UTC
udev-161-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/udev-161-1.fc14

Comment 13 Fedora Update System 2010-08-17 19:36:34 UTC
udev-161-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/udev-161-1.fc14

Comment 14 Fedora Update System 2010-08-24 01:32:15 UTC
udev-161-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.